summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorGuido Guenther <agx@sigxcpu.org>2006-12-29 18:19:56 +0100
committerGuido Guenther <agx@bogon.sigxcpu.org>2006-12-29 18:19:56 +0100
commitc18e74318d675fab42f68a7b3d84b4e8c5cb9a07 (patch)
tree925782588b681e1961fa953d053888dfd1230cca /debian/rules
parent8c7ae364d19ce0abff329360077835eb3e4a4b32 (diff)
depend on gtk-doc-tools, sgml2x and jade
(Closes: #404673) use docbook-utils insted of docbook-to-man
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules7
1 files changed, 4 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index 4cea659..eff6c1f 100755
--- a/debian/rules
+++ b/debian/rules
@@ -14,7 +14,7 @@ PYCHECKS=$(patsubst %,%.py,$(COMMANDS))
PYCHECK_LEVEL=Error
docs/%.1: docs/man.%.sgml
- docbook-to-man $< > $@
+ docbook2man -o docs/ $<
$(MANUAL): docs/manual.sgml docs/chapters/*.sgml docs/manpages/*.sgml
docbook-2-html -s gtk $<
@@ -26,6 +26,7 @@ $(MANUAL): docs/manual.sgml docs/chapters/*.sgml docs/manpages/*.sgml
build/git-buildpackage:: $(MANPAGES) $(MANUAL) $(PYCHECKS)
clean::
- -rm docs/*.1 git-*.py
- -rm -rf docs/manual-html/
+ -rm git-*.py
+ -rm docs/*.1 docs/manpage.*
+ -rm -r docs/manual-html/