summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorGuido Guenther <agx@sigxcpu.org>2006-09-12 15:08:19 +0200
committerGuido Guenther <agx@bogon.sigxcpu.org>2006-09-12 15:08:19 +0200
commit6ffbf26bfa0b4b6c62daaf8ae65a293a398342f1 (patch)
tree3db2530c4f27559527fa9de4198ccde90e27c2e1 /debian
parentd4d6d38ad6c90b19664ec7a6a9f89bf6753e82cf (diff)
add debian packaging
Diffstat (limited to 'debian')
-rw-r--r--debian/README.Debian6
-rw-r--r--debian/changelog6
-rw-r--r--debian/compat1
-rw-r--r--debian/control17
-rw-r--r--debian/copyright22
-rw-r--r--debian/dirs2
-rw-r--r--debian/docs1
-rw-r--r--debian/pycompat1
-rw-r--r--debian/pyversions1
-rwxr-xr-xdebian/rules11
10 files changed, 68 insertions, 0 deletions
diff --git a/debian/README.Debian b/debian/README.Debian
new file mode 100644
index 0000000..77d5ffe
--- /dev/null
+++ b/debian/README.Debian
@@ -0,0 +1,6 @@
+git-buildpackage for Debian
+---------------------------
+
+<possible notes regarding this package - if none, delete this file>
+
+ -- Guido Guenther <agx@sigxcpu.org>, Tue, 12 Sep 2006 14:55:57 +0200
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..ce31a69
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,6 @@
+git-buildpackage (0.01) unstable; urgency=low
+
+ * Initial release
+
+ -- Guido Guenther <agx@sigxcpu.org> Tue, 12 Sep 2006 14:55:57 +0200
+
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..7ed6ff8
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+5
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..5112ab4
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,17 @@
+Source: git-buildpackage
+Section: devel
+Priority: optional
+Maintainer: Guido Guenther <agx@sigxcpu.org>
+Build-Depends: cdbs, debhelper (>= 5), python-dev, python-support (>= 0.3)
+Standards-Version: 3.7.2
+
+Package: git-buildpackage
+Architecture: all
+Depends: ${python:Depends}, ${shlibs:Depends}, ${misc:Depends}, devscripts
+Suggests: git-load-dirs
+Description: bunch of scripts to ease the development of Debian packages with git
+ This package contains the following tools:
+ * git-import-dsc: import an existing Debian source package into a git
+ repository
+ * git-debuild: build a package out of a git repository, check for local
+ modifications and tag appropriately
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..6e2a6ac
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,22 @@
+This package was debianized by Guido Guenther <agx@sigxcpu.org> on
+Tue, 12 Sep 2006 14:55:57 +0200.
+
+It was downloaded from <fill in http/ftp site>
+
+Upstream Author: <put author(s) name and email here>
+
+Copyright: <put the year(s) of the copyright, and the names of the
+ copyright holder(s) here>
+
+License:
+
+<Put the license of the package here>
+
+
+The Debian packaging is (C) 2006, Guido Guenther <agx@sigxcpu.org> and
+is licensed under the GPL, see `/usr/share/common-licenses/GPL'.
+
+
+# Please also look if there are files or directories which have a
+# different copyright/license attached and list them here.
+
diff --git a/debian/dirs b/debian/dirs
new file mode 100644
index 0000000..ca882bb
--- /dev/null
+++ b/debian/dirs
@@ -0,0 +1,2 @@
+usr/bin
+usr/sbin
diff --git a/debian/docs b/debian/docs
new file mode 100644
index 0000000..e845566
--- /dev/null
+++ b/debian/docs
@@ -0,0 +1 @@
+README
diff --git a/debian/pycompat b/debian/pycompat
new file mode 100644
index 0000000..0cfbf08
--- /dev/null
+++ b/debian/pycompat
@@ -0,0 +1 @@
+2
diff --git a/debian/pyversions b/debian/pyversions
new file mode 100644
index 0000000..6b4950e
--- /dev/null
+++ b/debian/pyversions
@@ -0,0 +1 @@
+2.4
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..9464369
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,11 @@
+#!/usr/bin/make -f
+
+DEB_TAR_SRCDIR := python-dateutil
+DEB_AUTO_CLEANUP_RCS := yes
+
+DEB_PYTHON_SYSTEM = pysupport
+DEB_PYTHON_CLEAN_ARGS = --all
+
+# Add here any variable or target overrides you need
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/python-distutils.mk