summaryrefslogtreecommitdiff
path: root/orkaudio/Makefile.am
diff options
context:
space:
mode:
authorHenri Herscher <henri@oreka.org>2005-10-20 13:40:58 +0000
committerHenri Herscher <henri@oreka.org>2005-10-20 13:40:58 +0000
commit7e1d63dd9fd149e4934bf77095c8610fac786b04 (patch)
tree5fe486a1b0300c3b84fb559107a868e5cc2c95da /orkaudio/Makefile.am
parent467768fc956fc3e5a253373f26c71c681b31b6b8 (diff)
First checkin
git-svn-id: https://oreka.svn.sourceforge.net/svnroot/oreka/trunk@2 09dcff7a-b715-0410-9601-b79a96267cd0
Diffstat (limited to 'orkaudio/Makefile.am')
-rw-r--r--orkaudio/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/orkaudio/Makefile.am b/orkaudio/Makefile.am
new file mode 100644
index 0000000..659c8d1
--- /dev/null
+++ b/orkaudio/Makefile.am
@@ -0,0 +1,18 @@
+# not a GNU package. You can remove this line, if
+# have all needed files, that a GNU package needs
+AUTOMAKE_OPTIONS = foreign 1.4
+
+
+bin_PROGRAMS = orkaudio
+orkaudio_LDADD =
+orkaudio_LDFLAGS = -lsndfile -lACE -lxerces-c -llog4cxx -lorkbase
+orkaudio_SOURCES = OrkAudio.cpp AudioTape.cpp \
+ BatchProcessing.cpp CapturePluginProxy.cpp \
+ CapturePort.cpp Config.cpp ConfigManager.cpp \
+ Daemon.cpp ImmediateProcessing.cpp LogManager.cpp \
+ MultiThreadedServer.cpp Reporting.cpp
+AM_CPPFLAGS = -D_REENTRANT
+INCLUDES = -I@top_srcdir@ -I../orkbasecxx
+SUBDIRS = audiocaptureplugins messages audiofile
+orkaudio_LDADD = $(top_builddir)/messages/libmessages.la \
+ $(top_builddir)/audiofile/libaudiofile.la