summaryrefslogtreecommitdiff
path: root/orkbasecxx/Makefile.am
diff options
context:
space:
mode:
authorGerald Begumisa <ben_g@users.sourceforge.net>2009-01-07 13:07:31 +0000
committerGerald Begumisa <ben_g@users.sourceforge.net>2009-01-07 13:07:31 +0000
commit0e2a2e49077b79bd52d6c83c5202e452e7eea091 (patch)
tree58ae466e2c74be585548f10ffff96560099c9370 /orkbasecxx/Makefile.am
parentded03e95a1eb78cb16ef3a4a0dc9bb140bd748ba (diff)
Modified the orkaudio API, adding the record and pause HTTP commands. The record command commences or un-pauses recording while the pause command pauses recording - discarding RTP packets from when the pause command is issued. Both commands require the orkuid and party to be specified as HTTP parameters. Note that this represents a change in the arguments required for the StartCapture function in DLLs. Also added an event streaming feature which streams out all tape messages as they are reported in real-time to a client connected. Clients should connect via HTTP, on port 59150. The port is configurable by setting the parameter EventStreamingServerPort in config.xml
git-svn-id: https://oreka.svn.sourceforge.net/svnroot/oreka/trunk@590 09dcff7a-b715-0410-9601-b79a96267cd0
Diffstat (limited to 'orkbasecxx/Makefile.am')
-rw-r--r--orkbasecxx/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/orkbasecxx/Makefile.am b/orkbasecxx/Makefile.am
index 3f30d49..2810683 100644
--- a/orkbasecxx/Makefile.am
+++ b/orkbasecxx/Makefile.am
@@ -15,7 +15,7 @@ liborkbase_la_SOURCES = Filter.cpp g711.c \
CapturePluginProxy.cpp CapturePort.cpp \
Daemon.cpp ImmediateProcessing.cpp \
Reporting.cpp TapeFileNaming.cpp \
- PartyFilter.cpp
+ PartyFilter.cpp EventStreaming.cpp
#INCLUDES = -I/projects/ext/xmlrpc++/xmlrpc++0.7/src
SUBDIRS = messages serializers audiofile filters
liborkbase_la_LIBADD = $(top_builddir)/serializers/libserializers.la \