summaryrefslogtreecommitdiff
path: root/orkaudio/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'orkaudio/configure.ac')
-rw-r--r--orkaudio/configure.ac54
1 files changed, 54 insertions, 0 deletions
diff --git a/orkaudio/configure.ac b/orkaudio/configure.ac
new file mode 100644
index 0000000..4925a03
--- /dev/null
+++ b/orkaudio/configure.ac
@@ -0,0 +1,54 @@
+# -*- Autoconf -*-
+# Process this file with autoconf to produce a configure script.
+
+AC_PREREQ([2.61])
+AC_INIT([orkaudio], [1.0], [oreka@orex.com])
+AC_CONFIG_SRCDIR([OrkAudio.cpp])
+AC_CONFIG_HEADERS([config.h])
+AC_CONFIG_AUX_DIR([autotools])
+AM_INIT_AUTOMAKE
+
+AC_PREFIX_DEFAULT([/usr])
+
+# Checks for programs.
+AC_PROG_CXX
+AC_PROG_CC
+AC_PROG_LN_S
+AC_PROG_LIBTOOL
+
+# Checks for libraries.
+PKG_CHECK_MODULES([ORKBASE], [orkbase-1.0])
+# FIXME: Replace `main' with a function in `-lACE':
+AC_CHECK_LIB([ACE], [main])
+# FIXME: Replace `main' with a function in `-llog4cxx':
+AC_CHECK_LIB([log4cxx], [main])
+# FIXME: Replace `main' with a function in `-lpcap':
+AC_CHECK_LIB([pcap], [main])
+# FIXME: Replace `main' with a function in `-lsndfile':
+AC_CHECK_LIB([sndfile], [main])
+
+# Checks for header files.
+
+# Checks for typedefs, structures, and compiler characteristics.
+AC_HEADER_STDBOOL
+AC_C_INLINE
+AC_TYPE_SIZE_T
+
+# Checks for library functions.
+AC_FUNC_ERROR_AT_LINE
+AC_FUNC_MALLOC
+AC_FUNC_REALLOC
+AC_CHECK_FUNCS([gettimeofday localtime_r memchr memset strchr strncasecmp strstr])
+
+AC_CONFIG_FILES([Makefile
+ audiocaptureplugins/Makefile
+ audiocaptureplugins/generator/Makefile
+ audiocaptureplugins/voip/Makefile
+ filters/Makefile
+ filters/rtpmixer/Makefile
+ ])
+
+ORKAUDIO_PLUGINS_DIR=${libdir}/orkaudio/plugins
+AC_SUBST(ORKAUDIO_PLUGINS_DIR)
+
+AC_OUTPUT