summaryrefslogtreecommitdiff
path: root/orkbasecxx/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'orkbasecxx/configure.ac')
-rw-r--r--orkbasecxx/configure.ac60
1 files changed, 60 insertions, 0 deletions
diff --git a/orkbasecxx/configure.ac b/orkbasecxx/configure.ac
new file mode 100644
index 0000000..f5a14e0
--- /dev/null
+++ b/orkbasecxx/configure.ac
@@ -0,0 +1,60 @@
+# -*- Autoconf -*-
+# Process this file with autoconf to produce a configure script.
+
+AC_PREREQ([2.61])
+AC_INIT([orkbase], [1.0], [oreka@orex.com])
+AC_CONFIG_SRCDIR([LogManager.cpp])
+AC_CONFIG_HEADERS([config.h])
+AC_CONFIG_AUX_DIR([autotools])
+AM_INIT_AUTOMAKE
+
+AC_PREFIX_DEFAULT([/usr])
+
+# Checks for programs.
+AC_PROG_CXX
+AC_PROG_AWK
+AC_PROG_CC
+AC_PROG_CPP
+AC_PROG_INSTALL
+AC_PROG_LN_S
+AC_PROG_MAKE_SET
+AC_PROG_RANLIB
+AC_PROG_LIBTOOL
+
+# Checks for libraries.
+AC_CHECK_LIB([m], [cos])
+
+# Checks for header files.
+AC_CHECK_HEADERS([inttypes.h malloc.h memory.h stdlib.h string.h wchar.h wctype.h])
+
+# Checks for typedefs, structures, and compiler characteristics.
+AC_HEADER_STDBOOL
+AC_C_INLINE
+AC_TYPE_INT16_T
+AC_TYPE_INT32_T
+AC_TYPE_SIZE_T
+AC_TYPE_SSIZE_T
+AC_TYPE_UINT8_T
+
+# Checks for library functions.
+AC_FUNC_ALLOCA
+AC_FUNC_CHOWN
+AC_FUNC_ERROR_AT_LINE
+AC_FUNC_FORK
+AC_FUNC_MALLOC
+AC_FUNC_STRTOD
+AC_CHECK_FUNCS([gethrtime localtime_r memchr memmove memset mkdir pow sqrt strchr strerror strncasecmp strstr strtol strtoul])
+
+AC_CONFIG_FILES([Makefile
+ audiofile/Makefile
+ filters/Makefile
+ filters/audiogain/Makefile
+ filters/g722codec/Makefile
+ filters/gsm/Makefile
+ filters/gsm/gsm610/Makefile
+ filters/ilbc/Makefile
+ filters/ilbc/ilbc/Makefile
+ messages/Makefile
+ serializers/Makefile
+ orkbase-1.0.pc])
+AC_OUTPUT