summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile7
-rw-r--r--zend/arithmetic.h (renamed from src/arithmetic.h)0
-rw-r--r--zend/base.cpp (renamed from src/base.cpp)0
-rw-r--r--zend/boolmember.h (renamed from src/boolmember.h)0
-rw-r--r--zend/callable.cpp (renamed from src/callable.cpp)0
-rw-r--r--zend/callable.h (renamed from src/callable.h)0
-rw-r--r--zend/classbase.cpp (renamed from src/classbase.cpp)0
-rw-r--r--zend/classimpl.cpp (renamed from src/classimpl.cpp)0
-rw-r--r--zend/classimpl.h (renamed from src/classimpl.h)0
-rw-r--r--zend/extension.cpp (renamed from src/extension.cpp)0
-rw-r--r--zend/extensionimpl.cpp (renamed from src/extensionimpl.cpp)0
-rw-r--r--zend/extensionimpl.h (renamed from src/extensionimpl.h)0
-rw-r--r--zend/floatmember.h (renamed from src/floatmember.h)0
-rw-r--r--zend/function.h (renamed from src/function.h)0
-rw-r--r--zend/global.cpp (renamed from src/global.cpp)0
-rw-r--r--zend/globals.cpp (renamed from src/globals.cpp)0
-rw-r--r--zend/hashiterator.h (renamed from src/hashiterator.h)0
-rw-r--r--zend/hashmember.cpp (renamed from src/hashmember.cpp)0
-rw-r--r--zend/includes.h (renamed from src/includes.h)6
-rw-r--r--zend/init.h (renamed from src/init.h)0
-rw-r--r--zend/invaliditerator.h (renamed from src/invaliditerator.h)0
-rw-r--r--zend/iteratorimpl.cpp (renamed from src/iteratorimpl.cpp)0
-rw-r--r--zend/iteratorimpl.h (renamed from src/iteratorimpl.h)0
-rw-r--r--zend/member.h (renamed from src/member.h)0
-rw-r--r--zend/members.cpp (renamed from src/members.cpp)0
-rw-r--r--zend/method.h (renamed from src/method.h)0
-rw-r--r--zend/modifiers.cpp (renamed from src/modifiers.cpp)0
-rw-r--r--zend/namespace.cpp (renamed from src/namespace.cpp)0
-rw-r--r--zend/notimplemented.h (renamed from src/notimplemented.h)0
-rw-r--r--zend/nullmember.h (renamed from src/nullmember.h)0
-rw-r--r--zend/numericmember.h (renamed from src/numericmember.h)0
-rw-r--r--zend/object.cpp (renamed from src/object.cpp)0
-rw-r--r--zend/objectimpl.h (renamed from src/objectimpl.h)0
-rw-r--r--zend/origexception.h (renamed from src/origexception.h)0
-rw-r--r--zend/parametersimpl.h (renamed from src/parametersimpl.h)0
-rw-r--r--zend/property.h (renamed from src/property.h)0
-rw-r--r--zend/streambuf.cpp (renamed from src/streambuf.cpp)0
-rw-r--r--zend/streambuf.h (renamed from src/streambuf.h)0
-rw-r--r--zend/streams.cpp (renamed from src/streams.cpp)0
-rw-r--r--zend/stringmember.h (renamed from src/stringmember.h)0
-rw-r--r--zend/super.cpp (renamed from src/super.cpp)0
-rw-r--r--zend/traverseiterator.h (renamed from src/traverseiterator.h)0
-rw-r--r--zend/value.cpp (renamed from src/value.cpp)0
-rw-r--r--zend/valueiterator.cpp (renamed from src/valueiterator.cpp)0
-rw-r--r--zend/valueiteratorimpl.h (renamed from src/valueiteratorimpl.h)0
45 files changed, 7 insertions, 6 deletions
diff --git a/Makefile b/Makefile
index 9a66157..5955a3d 100644
--- a/Makefile
+++ b/Makefile
@@ -120,12 +120,13 @@ MKDIR = mkdir -p
# The source files
#
# For this we use a special Makefile function that automatically scans the
-# src/ directory for all *.cpp files. No changes are probably necessary here
+# src/, zend/ and hhvm/ directories for all *.cpp files. No changes are
+# probably necessary here
#
SOURCES = $(wildcard src/*.cpp)
-PHP_SOURCES = $(wildcard src/zend/*.cpp)
-HHVM_SOURCES = $(wildcard src/hhvm/*.cpp)
+PHP_SOURCES = $(wildcard zend/*.cpp)
+HHVM_SOURCES = $(wildcard hhvm/*.cpp)
#
# The object files
diff --git a/src/arithmetic.h b/zend/arithmetic.h
index 20e346e..20e346e 100644
--- a/src/arithmetic.h
+++ b/zend/arithmetic.h
diff --git a/src/base.cpp b/zend/base.cpp
index 5d15011..5d15011 100644
--- a/src/base.cpp
+++ b/zend/base.cpp
diff --git a/src/boolmember.h b/zend/boolmember.h
index 5b5d43d..5b5d43d 100644
--- a/src/boolmember.h
+++ b/zend/boolmember.h
diff --git a/src/callable.cpp b/zend/callable.cpp
index 737b85b..737b85b 100644
--- a/src/callable.cpp
+++ b/zend/callable.cpp
diff --git a/src/callable.h b/zend/callable.h
index 65ce719..65ce719 100644
--- a/src/callable.h
+++ b/zend/callable.h
diff --git a/src/classbase.cpp b/zend/classbase.cpp
index 18d81d5..18d81d5 100644
--- a/src/classbase.cpp
+++ b/zend/classbase.cpp
diff --git a/src/classimpl.cpp b/zend/classimpl.cpp
index d63956a..d63956a 100644
--- a/src/classimpl.cpp
+++ b/zend/classimpl.cpp
diff --git a/src/classimpl.h b/zend/classimpl.h
index febdbca..febdbca 100644
--- a/src/classimpl.h
+++ b/zend/classimpl.h
diff --git a/src/extension.cpp b/zend/extension.cpp
index 9685b32..9685b32 100644
--- a/src/extension.cpp
+++ b/zend/extension.cpp
diff --git a/src/extensionimpl.cpp b/zend/extensionimpl.cpp
index 9562362..9562362 100644
--- a/src/extensionimpl.cpp
+++ b/zend/extensionimpl.cpp
diff --git a/src/extensionimpl.h b/zend/extensionimpl.h
index cc37354..cc37354 100644
--- a/src/extensionimpl.h
+++ b/zend/extensionimpl.h
diff --git a/src/floatmember.h b/zend/floatmember.h
index 9b5d4f2..9b5d4f2 100644
--- a/src/floatmember.h
+++ b/zend/floatmember.h
diff --git a/src/function.h b/zend/function.h
index 4c34ac7..4c34ac7 100644
--- a/src/function.h
+++ b/zend/function.h
diff --git a/src/global.cpp b/zend/global.cpp
index 7eea8e7..7eea8e7 100644
--- a/src/global.cpp
+++ b/zend/global.cpp
diff --git a/src/globals.cpp b/zend/globals.cpp
index 8132ef3..8132ef3 100644
--- a/src/globals.cpp
+++ b/zend/globals.cpp
diff --git a/src/hashiterator.h b/zend/hashiterator.h
index b1f409f..b1f409f 100644
--- a/src/hashiterator.h
+++ b/zend/hashiterator.h
diff --git a/src/hashmember.cpp b/zend/hashmember.cpp
index f6f8483..f6f8483 100644
--- a/src/hashmember.cpp
+++ b/zend/hashmember.cpp
diff --git a/src/includes.h b/zend/includes.h
index 0019244..f547eb2 100644
--- a/src/includes.h
+++ b/zend/includes.h
@@ -23,9 +23,9 @@
// for debug
#include <iostream>
-#define ZTS
-#define THREAD_T pthread_t
-#define MUTEX_T pthread_mutex_t *
+//#define ZTS
+//#define THREAD_T pthread_t
+//#define MUTEX_T pthread_mutex_t *
/**
* PHP includes
diff --git a/src/init.h b/zend/init.h
index 8f914f5..8f914f5 100644
--- a/src/init.h
+++ b/zend/init.h
diff --git a/src/invaliditerator.h b/zend/invaliditerator.h
index 388eca8..388eca8 100644
--- a/src/invaliditerator.h
+++ b/zend/invaliditerator.h
diff --git a/src/iteratorimpl.cpp b/zend/iteratorimpl.cpp
index 2750ddb..2750ddb 100644
--- a/src/iteratorimpl.cpp
+++ b/zend/iteratorimpl.cpp
diff --git a/src/iteratorimpl.h b/zend/iteratorimpl.h
index 0a815e2..0a815e2 100644
--- a/src/iteratorimpl.h
+++ b/zend/iteratorimpl.h
diff --git a/src/member.h b/zend/member.h
index 7aa01d8..7aa01d8 100644
--- a/src/member.h
+++ b/zend/member.h
diff --git a/src/members.cpp b/zend/members.cpp
index 1965807..1965807 100644
--- a/src/members.cpp
+++ b/zend/members.cpp
diff --git a/src/method.h b/zend/method.h
index dd18a9a..dd18a9a 100644
--- a/src/method.h
+++ b/zend/method.h
diff --git a/src/modifiers.cpp b/zend/modifiers.cpp
index 3720730..3720730 100644
--- a/src/modifiers.cpp
+++ b/zend/modifiers.cpp
diff --git a/src/namespace.cpp b/zend/namespace.cpp
index bea31a1..bea31a1 100644
--- a/src/namespace.cpp
+++ b/zend/namespace.cpp
diff --git a/src/notimplemented.h b/zend/notimplemented.h
index ee99254..ee99254 100644
--- a/src/notimplemented.h
+++ b/zend/notimplemented.h
diff --git a/src/nullmember.h b/zend/nullmember.h
index e035897..e035897 100644
--- a/src/nullmember.h
+++ b/zend/nullmember.h
diff --git a/src/numericmember.h b/zend/numericmember.h
index 0a040d3..0a040d3 100644
--- a/src/numericmember.h
+++ b/zend/numericmember.h
diff --git a/src/object.cpp b/zend/object.cpp
index d7fc158..d7fc158 100644
--- a/src/object.cpp
+++ b/zend/object.cpp
diff --git a/src/objectimpl.h b/zend/objectimpl.h
index 41bed53..41bed53 100644
--- a/src/objectimpl.h
+++ b/zend/objectimpl.h
diff --git a/src/origexception.h b/zend/origexception.h
index 775e412..775e412 100644
--- a/src/origexception.h
+++ b/zend/origexception.h
diff --git a/src/parametersimpl.h b/zend/parametersimpl.h
index fd14238..fd14238 100644
--- a/src/parametersimpl.h
+++ b/zend/parametersimpl.h
diff --git a/src/property.h b/zend/property.h
index f0fd46f..f0fd46f 100644
--- a/src/property.h
+++ b/zend/property.h
diff --git a/src/streambuf.cpp b/zend/streambuf.cpp
index e258b4e..e258b4e 100644
--- a/src/streambuf.cpp
+++ b/zend/streambuf.cpp
diff --git a/src/streambuf.h b/zend/streambuf.h
index ed1506a..ed1506a 100644
--- a/src/streambuf.h
+++ b/zend/streambuf.h
diff --git a/src/streams.cpp b/zend/streams.cpp
index ba6d916..ba6d916 100644
--- a/src/streams.cpp
+++ b/zend/streams.cpp
diff --git a/src/stringmember.h b/zend/stringmember.h
index e58cd3d..e58cd3d 100644
--- a/src/stringmember.h
+++ b/zend/stringmember.h
diff --git a/src/super.cpp b/zend/super.cpp
index 506d4a5..506d4a5 100644
--- a/src/super.cpp
+++ b/zend/super.cpp
diff --git a/src/traverseiterator.h b/zend/traverseiterator.h
index 16f1ce7..16f1ce7 100644
--- a/src/traverseiterator.h
+++ b/zend/traverseiterator.h
diff --git a/src/value.cpp b/zend/value.cpp
index 2ca1585..2ca1585 100644
--- a/src/value.cpp
+++ b/zend/value.cpp
diff --git a/src/valueiterator.cpp b/zend/valueiterator.cpp
index 65c687c..65c687c 100644
--- a/src/valueiterator.cpp
+++ b/zend/valueiterator.cpp
diff --git a/src/valueiteratorimpl.h b/zend/valueiteratorimpl.h
index 82c888d..82c888d 100644
--- a/src/valueiteratorimpl.h
+++ b/zend/valueiteratorimpl.h