summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile17
1 files changed, 17 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..2eb652a
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,17 @@
+PREFIX = /usr
+INCLUDE_DIR = ${PREFIX}/include
+LIBRARY_DIR = ${PREFIX}/lib
+
+all:
+ cd src; $(MAKE)
+
+clean:
+ cd src; $(MAKE) clean
+
+install:
+ mkdir -p ${INCLUDE_DIR}/phpcpp
+ mkdir -p ${LIBRARY_DIR}
+ cp -f phpcpp.h ${INCLUDE_DIR}
+ cp -f include/*.h ${INCLUDE_DIR}/phpcpp
+ cp -f src/libphpcpp.so ${LIBRARY_DIR}
+