summaryrefslogtreecommitdiff
path: root/tests/simple/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/simple/Makefile')
-rw-r--r--tests/simple/Makefile22
1 files changed, 0 insertions, 22 deletions
diff --git a/tests/simple/Makefile b/tests/simple/Makefile
deleted file mode 100644
index e60be3a..0000000
--- a/tests/simple/Makefile
+++ /dev/null
@@ -1,22 +0,0 @@
-CPP = g++
-RM = rm -f
-CPP_FLAGS = -Wall -c -I. -O2 -std=c++11
-
-LD = g++
-LD_FLAGS = -Wall -shared -O2
-RESULT = simple.so
-
-SOURCES = $(wildcard *.cpp)
-OBJECTS = $(SOURCES:%.cpp=%.o)
-
-all: ${OBJECTS} ${RESULT}
-
-${RESULT}: ${OBJECTS}
- ${LD} ${LD_FLAGS} -o $@ ${OBJECTS} -lphpcpp
-
-clean:
- ${RM} *.obj *~* ${OBJECTS} ${RESULT}
-
-${OBJECTS}:
- ${CPP} ${CPP_FLAGS} -fpic -o $@ ${@:%.o=%.cpp}
-