summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 450d5c1..23929f1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -90,6 +90,8 @@ AST_C_DEFINE_CHECK([DAHDI], [DAHDI_CODE], [dahdi/user.h])
AST_EXT_LIB_CHECK([NEWT], [newt], [newtBell], [newt.h])
AST_EXT_LIB_CHECK([USB], [usb], [usb_init], [usb.h])
+AST_C_DEFINE_CHECK([HDLC], [GENERIC_HDLC_VERSION], [linux/hdlc.h], [4])
+
AC_ARG_WITH(selinux,
[AS_HELP_STRING([--with-selinux],
[enable (with) / disable (without) SELinux])],
@@ -144,6 +146,16 @@ case "$with_ppp" in
;;
esac
+if test "x${PBX_HDLC}" == "x1"; then
+ AC_EGREP_CPP([VERSION = 4],
+ [#include <linux/hdlc.h>
+ VERSION = GENERIC_HDLC_VERSION], [], [PBX_HDLC=0])
+fi
+
+if test "x${PBX_HDLC}" != "x1"; then
+ AC_MSG_NOTICE([GENERIC_HDLC_VERSION version 4 not found, disabling sethdlc.])
+fi
+
if test "x${PBX_DAHDI}" != "x1"; then
AC_MSG_NOTICE([***])
AC_MSG_NOTICE([*** Building this package requires DAHDI support. *** ])