summaryrefslogtreecommitdiff
path: root/tests/cpp
diff options
context:
space:
mode:
authorvalmat <ufabiz@gmail.com>2014-03-21 06:23:01 +0600
committervalmat <ufabiz@gmail.com>2014-03-21 06:23:01 +0600
commitae524a6c76f207636e3b5e3e6ccb83dcefdb14d1 (patch)
treed44e443abd990637747fe44c4ad4d5018a7bfc6f /tests/cpp
parent6d42a8f99cbe98201a0d52ab276f6929b66cfe4f (diff)
Small improvements
Regained the ability to run the tests (script tests/test.sh) with option -m (Valgrind) added option -q (Quiet) Full range of options, see $ ./test.sh -h Some other improvements (see diff)
Diffstat (limited to 'tests/cpp')
-rw-r--r--tests/cpp/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/tests/cpp/Makefile b/tests/cpp/Makefile
index 0b6800c..e0c32ba 100644
--- a/tests/cpp/Makefile
+++ b/tests/cpp/Makefile
@@ -42,8 +42,7 @@ NAME = extfortest
# this with a different fixed directory
#
-#EXTENSION_DIR = $(shell php-config --extension-dir)
-EXTENSION_DIR = ../..
+EXTENSION_DIR = $(shell php-config --extension-dir)
#
@@ -87,10 +86,9 @@ LINKER = g++
# one: the PHP-CPP library), you should update the LINKER_DEPENDENCIES variable
# with a list of all flags that should be passed to the linker.
#
+
LIB_DIR=$(shell cd ../.. && pwd)
-#COMPILER_FLAGS = -Wall -c -O2 -std=c++11 -fpic -o
-#COMPILER_FLAGS = -Wall -c -g -std=c++11 -fpic -o
-COMPILER_FLAGS = -Wall -c -g -std=c++11 -fpic -I. -I"${LIB_DIR}/include" -o
+COMPILER_FLAGS = -Wall -c -O2 -std=c++11 -fpic -I"${LIB_DIR}/include" -o
LINKER_FLAGS = -shared -L"${LIB_DIR}"
LINKER_DEPENDENCIES = -lphpcpp
@@ -131,7 +129,7 @@ ${EXTENSION}: ${OBJECTS}
${OBJECTS}:
${COMPILER} ${COMPILER_FLAGS} $@ ${@:%.o=%.cpp}
-# Do not install this extention
+# Do not install this extension
#install:
# ${CP} ${EXTENSION} ${EXTENSION_DIR}
# ${CP} ${INI} ${INI_DIR}