summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKevin P. Fleming <kpfleming@digium.com>2008-01-02 14:20:46 +0000
committerKevin P. Fleming <kpfleming@digium.com>2008-01-02 14:20:46 +0000
commit78c35db4dab6b13ca468568892f2e25f3070f6c9 (patch)
treeff3bbe9b1a68e4aaa64837ea242cb9eb320a2ed0 /configure.ac
parent04a10c145bb11d26960e78afda49c037216ff73d (diff)
actually check for a function present in libiconv (don't know how this test could have worked before) and don't do the check on Linux/GNU systems because libiconv is not present there and attempting to link with '-liconv' always fails (it's not necessary as the iconv functionality is always available)
git-svn-id: https://origsvn.digium.com/svn/asterisk/trunk@95817 65c4cc65-6c06-0410-ace0-fbb531ad65f3
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index c7aa642a9..1a64cf514 100644
--- a/configure.ac
+++ b/configure.ac
@@ -618,7 +618,11 @@ if test "${USE_GSM}" != "no"; then
fi
fi
-AST_EXT_LIB_CHECK([ICONV], [iconv], [libiconv], [iconv.h])
+if test "${host_os}" != "linux-gnu" ; then
+ AST_EXT_LIB_CHECK([ICONV], [iconv], [iconv_open], [iconv.h])
+else
+ PBX_ICONV=1
+fi
AST_EXT_LIB_CHECK([IKSEMEL], [iksemel], [iks_start_sasl], [iksemel.h])