summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWalter Doekes <walter+github@wjd.nu>2017-03-28 20:01:16 +0200
committerGeorge Joseph <gjoseph@digium.com>2017-03-30 16:09:40 -0600
commit7954b39a505b1ff0bf4a1326125b701d30c25919 (patch)
tree5618e14b0763e7dacce71770ba8ac9402ae33fe9 /configure.ac
parente52ced02d8a70993301d7cfb5e4a98bb97010a71 (diff)
build: Fix deb build issues with fakeroot
If DESTDIR is set, don't call ldconfig. Assume that DESTDIR is used to create a binary archive. The ldconfig call should be delegated to the archive postinst script. This fixes the case where fakeroot wraps 'make install' causing $EUID to be 0 even though it doesn't have permission to call ldconfig. The previous logic in configure.ac to detect and correct libdir has been removed as it was not completely accurate. CentOS 64-bit users should again specifiy --libdir=/usr/lib64 when configuring to prevent install to /usr/lib. Updated Makefile:check-old-libdir to check for orphans in lib64 when installing to lib as well as orphans in lib when installing to lib64. Updated Makefile and main/Makefile uninstall targets to remove the orphans using the new logic. ASTERISK-26705 Change-Id: I51739d4a03e60bff38be719b8d2ead0007afdd51
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 0 insertions, 21 deletions
diff --git a/configure.ac b/configure.ac
index 37449a1d5..d3268954c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -135,27 +135,6 @@ if test ${prefix} = ${ac_default_prefix} || test ${prefix} = 'NONE'; then
fi
fi
-#
-# The following code for detecting lib64 was taken from Fedora's
-# /usr/share/config.site with a modification to check that the
-# /usr/lib64 directory actually exists. This prevents libdir from
-# being set to /usr/lib64 on 64-bit systems that still use /usr/lib.
-#
-if test "$prefix" = /usr ||\
- { test "$prefix" = NONE && test "$ac_default_prefix" = /usr ; }
-then
- for i in x86_64 ppc64 s390x aarch64; do
- if test $host_cpu = $i; then
- if test "$libdir" = '${exec_prefix}/lib' &&\
- { test -d "${exec_prefix}/lib64" || test -d "${ac_default_prefix}/lib64" ; } ; then
- libdir='${exec_prefix}/lib64'
- AC_MSG_NOTICE([ Setting libdir=${libdir} ])
- fi
- break
- fi
- done
-fi
-
BUILD_PLATFORM=${build}
BUILD_CPU=${build_cpu}
BUILD_VENDOR=${build_vendor}