summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKinsey Moore <kmoore@digium.com>2012-04-12 15:25:47 +0000
committerKinsey Moore <kmoore@digium.com>2012-04-12 15:25:47 +0000
commit8696daadf8c129d92c52b85d471fcacca9e50a85 (patch)
treeee347b0c1323438d9fcc9e7662d1ced2eb87a401 /configure.ac
parent683eacb59a2d322d57c4c9bd9f6e22501c2c244b (diff)
Simplify build system architecture optimization
This change to the build system rips out any usage of PROC along with architecture-specific optimizations in favor of using -march=native where it is supported. This fixes broken builds on 64bit Intel systems and results in better optimized code on systems running GCC 4.2+. Review: https://reviewboard.asterisk.org/r/1852/ (closes issue ASTERISK-19462) ........ Merged revisions 361955 from http://svn.asterisk.org/svn/asterisk/branches/1.8 ........ Merged revisions 361956 from http://svn.asterisk.org/svn/asterisk/branches/10 git-svn-id: https://origsvn.digium.com/svn/asterisk/trunk@361968 65c4cc65-6c06-0410-ace0-fbb531ad65f3
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 10 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 4ba987316..8e22214dd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1009,15 +1009,20 @@ else
fi
AC_SUBST(AST_SHADOW_WARNINGS)
-AC_MSG_CHECKING(for -march=native)
+AC_MSG_CHECKING(for -march=native support)
if $(${CC} -march=native -S -o /dev/null -xc /dev/null > /dev/null 2>&1); then
- AC_MSG_RESULT(yes)
- AST_MARCH_NATIVE="-march=native"
+ if test "${CONFIG_CFLAGS}" = ""; then
+ AC_MSG_RESULT(yes)
+ AST_NATIVE_ARCH=1
+ else
+ AC_MSG_RESULT(user CFLAGS present)
+ AST_NATIVE_ARCH=
+ fi
else
AC_MSG_RESULT(no)
- AST_MARCH_NATIVE=
+ AST_NATIVE_ARCH=
fi
-AC_SUBST(AST_MARCH_NATIVE)
+AC_SUBST(AST_NATIVE_ARCH)
AC_MSG_CHECKING(for sysinfo)
AC_LINK_IFELSE(