summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKevin P. Fleming <kpfleming@digium.com>2012-07-23 21:27:56 +0000
committerKevin P. Fleming <kpfleming@digium.com>2012-07-23 21:27:56 +0000
commitb5193428a7825005a36434e4917dcbaca64ad21d (patch)
treebee56a50520d343be4f852926c2af730f4917a5f /configure.ac
parentb6a0ae0b35797bcdf5368e7d0e2223c6321c9b21 (diff)
Enable usage of system-provided iLBC library.
The WebRTC version of the iLBC codec is now package as a library and is available on some platforms. This patch allows codec_ilbc to be built against that library if it is present. Review: https://reviewboard.asterisk.org/r/1964/ git-svn-id: https://origsvn.digium.com/svn/asterisk/trunk@370407 65c4cc65-6c06-0410-ace0-fbb531ad65f3
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 21 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index bdc8889ae..55377d318 100644
--- a/configure.ac
+++ b/configure.ac
@@ -390,6 +390,7 @@ AST_EXT_LIB_SETUP([CRYPTO], [OpenSSL Cryptography], [crypto])
AST_EXT_LIB_SETUP([DAHDI], [DAHDI], [dahdi])
AST_EXT_LIB_SETUP([FFMPEG], [Ffmpeg and avcodec], [avcodec])
AST_EXT_LIB_SETUP([GSM], [External GSM], [gsm], [, use 'internal' GSM otherwise])
+AST_EXT_LIB_SETUP([ILBC], [System iLBC], [ilbc], [, use 'internal' iLBC otherwise])
AST_EXT_LIB_SETUP([GTK2], [gtk2], [gtk2])
AST_EXT_LIB_SETUP([GMIME], [GMime], [gmime])
AST_EXT_LIB_SETUP([OPENH323], [OpenH323], [h323])
@@ -1250,6 +1251,26 @@ if test "${USE_GSM}" != "no"; then
fi
fi
+ILBC_INTERNAL="yes"
+AC_SUBST(ILBC_INTERNAL)
+ILBC_SYSTEM="yes"
+if test "${USE_ILBC}" != "no"; then
+ if test "${ILBC_DIR}" = "internal"; then
+ ILBC_SYSTEM="no"
+ elif test "${ILBC_DIR}" != ""; then
+ ILBC_INTERNAL="no"
+ fi
+ if test "${ILBC_SYSTEM}" = "yes"; then
+ AST_PKG_CONFIG_CHECK(ILBC, libilbc)
+ if test "$PBX_ILBC" = '1'; then
+ ILBC_INTERNAL='no'
+ fi
+ fi
+ if test "${ILBC_INTERNAL}" = "yes"; then
+ PBX_ILBC=1
+ fi
+fi
+
AST_EXT_LIB_CHECK([ICONV], [iconv], [iconv_open], [iconv.h])
# GNU libiconv #define's iconv_open to libiconv_open, so we need to search for that symbol
AST_EXT_LIB_CHECK([ICONV], [iconv], [libiconv_open], [iconv.h])