summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid M. Lee <dlee@digium.com>2013-01-18 22:42:38 +0000
committerDavid M. Lee <dlee@digium.com>2013-01-18 22:42:38 +0000
commitbc97a4ded17bee63555b6215a5ec3d3206f8eec1 (patch)
treef91cbdd19059bbf4c31bd649bcde88f7aa509bc3 /configure.ac
parentceedf6d3b5bb49deaf181e1d1af2f20b990a3da1 (diff)
Up the minimum OS X version to 10.6.
* This allows us to remove some special-case build logic. * 10.5 is down to less that 8% of the OS X market share. 10.4 is down to under 2%. * Apple is no longer releasing security updates for 10.5 and earlier. git-svn-id: https://origsvn.digium.com/svn/asterisk/trunk@379495 65c4cc65-6c06-0410-ace0-fbb531ad65f3
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 1 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index b5f4d29a2..e90682754 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1071,18 +1071,7 @@ if test "${check_rpath}" != yes; then
elif test "${prefix}" = /usr || test "${prefix}" = NONE; then
AC_MSG_RESULT(not needed)
else
- case "${host_os}" in
- darwin*)
- AC_MSG_RESULT(not supported)
- # We set macosx_version_min to 10.4, which doesn't
- # support rpath. However, we set install_name on our
- # dylibs, so it's not strictly necessary.
- ;;
- *)
- AC_MSG_RESULT(required)
- AST_RPATH="-Wl,-rpath,${libdir}"
- ;;
- esac
+ AST_RPATH="-Wl,-rpath,${libdir}"
fi
AC_SUBST(AST_RPATH)