summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJenkins2 <jenkins2@gerrit.asterisk.org>2017-06-14 10:39:13 -0500
committerGerrit Code Review <gerrit2@gerrit.digium.api>2017-06-14 10:39:13 -0500
commite26d15fabbd266b33eff26370d503a9855fad5f7 (patch)
tree3ba76d52859405e6fb5e3cfdc5e58f58d7a79b61 /configure.ac
parent44d4b55697ecc2b1a6f814059f9cc5e221e0143d (diff)
parent68de35a6a01e2a1fe732e156b73f800bb672a421 (diff)
Merge "CFLAGS for BIND8 support" into 13
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 120b0f831..de4bce247 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1334,6 +1334,18 @@ AC_LINK_IFELSE(
AC_MSG_RESULT(no)
)
+AC_MSG_CHECKING(for BIND_8_COMPAT required)
+AC_COMPILE_IFELSE([AC_LANG_PROGRAM(
+[[
+#undef BIND_8_COMPAT
+#include <arpa/nameser.h>
+]],
+[[int x = NXDOMAIN]])],
+AC_MSG_RESULT(no),
+AC_MSG_RESULT(yes)
+[BIND8_CFLAGS=-DBIND_8_COMPAT])
+AC_SUBST(BIND8_CFLAGS)
+
AST_C_DEFINE_CHECK([GLOB_NOMAGIC], [GLOB_NOMAGIC], [glob.h])
AST_C_DEFINE_CHECK([GLOB_BRACE], [GLOB_BRACE], [glob.h])