summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJoshua Colp <jcolp@digium.com>2008-02-21 16:44:57 +0000
committerJoshua Colp <jcolp@digium.com>2008-02-21 16:44:57 +0000
commitedad328409e5e6f412cdee6cf2a3ed3de8e45b49 (patch)
tree5404d87eebf50224d2cb13311a36b5c593e50032 /configure.ac
parent1a6711a42d1c81aa7d92651dad4115529c307960 (diff)
Disable epoll as it has caused more obscure issues then any of my previous code. I will continue to work on it in a separate branch to make it stable for a release and test it against the following issues.
(closes issue #11253) Reported by: falves11 (closes issue #11657) Reported by: davevg (closes issue #11033) Reported by: falves11 git-svn-id: https://origsvn.digium.com/svn/asterisk/trunk@104019 65c4cc65-6c06-0410-ace0-fbb531ad65f3
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac28
1 files changed, 14 insertions, 14 deletions
diff --git a/configure.ac b/configure.ac
index 883198f1c..82a7d4ec2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -414,20 +414,20 @@ AC_MSG_RESULT(no)
AST_C_DEFINE_CHECK([PTHREAD_RECURSIVE_MUTEX_INITIALIZER_NP], [PTHREAD_RECURSIVE_MUTEX_INITIALIZER_NP], [pthread.h])
-if test "${cross_compiling}" = "no";
-then
-AC_MSG_CHECKING(for working epoll support)
-AC_LINK_IFELSE(
-AC_LANG_PROGRAM([#include <sys/epoll.h>], [int res = epoll_create(10);
- if (res < 0)
- return 1;
- close (res);
- return 0;]),
-AC_MSG_RESULT(yes)
-AC_DEFINE([HAVE_EPOLL], 1, [Define to 1 if your system has working epoll support.]),
-AC_MSG_RESULT(no)
-)
-fi
+#if test "${cross_compiling}" = "no";
+#then
+#AC_MSG_CHECKING(for working epoll support)
+#AC_LINK_IFELSE(
+#AC_LANG_PROGRAM([#include <sys/epoll.h>], [int res = epoll_create(10);
+# if (res < 0)
+# return 1;
+# close (res);
+# return 0;]),
+#AC_MSG_RESULT(yes)
+#AC_DEFINE([HAVE_EPOLL], 1, [Define to 1 if your system has working epoll support.]),
+#AC_MSG_RESULT(no)
+#)
+#fi
AC_MSG_CHECKING(for compiler atomic operations)
AC_LINK_IFELSE(