summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJenkins2 <jenkins2@gerrit.asterisk.org>2018-01-09 06:39:28 -0600
committerGerrit Code Review <gerrit2@gerrit.digium.api>2018-01-09 06:39:28 -0600
commitedbfcfcae18ca3f020eda37eaae3716747f33209 (patch)
tree6c1d313e7786750d01965280f082ea51649479f9 /configure.ac
parente8f81a2905b121b87d5d3e9b63f74b6bf98596c0 (diff)
parentaa52c52b215405dc467800c0ee4e888fb10376e1 (diff)
Merge "BuildSystem: Really do not pass unknown-warning options to the compiler." into 13
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index c617cf084..e333fafa1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1196,7 +1196,7 @@ LDFLAGS="${saved_sanitize_LDFLAGS}"
AC_SUBST(AST_UNDEFINED_SANITIZER)
AC_MSG_CHECKING(for -Wdeclaration-after-statement support)
-if $(${CC} -Wdeclaration-after-statement -S -o /dev/null -xc /dev/null > /dev/null 2>&1); then
+if $(${CC} -Wdeclaration-after-statement -Werror -S -o /dev/null -xc /dev/null > /dev/null 2>&1); then
AC_MSG_RESULT(yes)
AST_DECLARATION_AFTER_STATEMENT=-Wdeclaration-after-statement
else
@@ -1236,7 +1236,7 @@ fi
AC_SUBST(AST_NO_STRICT_OVERFLOW)
AC_MSG_CHECKING(for -Wno-format-truncation)
-if $(${CC} -O2 -Wno-format-truncation -S -o /dev/null -xc /dev/null > /dev/null 2>&1); then
+if $(${CC} -Wno-format-truncation -Werror -S -o /dev/null -xc /dev/null > /dev/null 2>&1); then
AC_MSG_RESULT(yes)
AST_NO_FORMAT_TRUNCATION=-Wno-format-truncation
else
@@ -1246,7 +1246,7 @@ fi
AC_SUBST(AST_NO_FORMAT_TRUNCATION)
AC_MSG_CHECKING(for -Wshadow)
-if $(${CC} -Wshadow -S -o /dev/null -xc /dev/null > /dev/null 2>&1); then
+if $(${CC} -Wshadow -Werror -S -o /dev/null -xc /dev/null > /dev/null 2>&1); then
AC_MSG_RESULT(yes)
AST_SHADOW_WARNINGS=-Wshadow
else