summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJoshua Colp <jcolp@digium.com>2017-11-17 09:18:39 -0600
committerGerrit Code Review <gerrit2@gerrit.digium.api>2017-11-17 09:18:39 -0600
commitef8ee3ee69fb1b2f9bb2694217d8dfdf124d251f (patch)
tree70e64607303e71e484c63476cd6b0dbd0c14052b /configure.ac
parent2e9c7f9b8f080a4b5847da690633fd090c842088 (diff)
parent76e640bd53438232870c29051e3ac7a3514eab37 (diff)
Merge "Build: Make function constructor/destructor attributes mandatory." into 13
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index da0400516..30ff4ac31 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1122,7 +1122,14 @@ AST_GCC_ATTRIBUTE(sentinel)
AST_GCC_ATTRIBUTE(warn_unused_result)
AST_GCC_ATTRIBUTE(may_alias)
AST_GCC_ATTRIBUTE(constructor)
+if test "$ax_cv_have_func_attribute_constructor" != "1"; then
+ AC_MSG_ERROR([*** Function constructor attribute is not supported by your compiler.])
+fi
+
AST_GCC_ATTRIBUTE(destructor)
+if test "$ax_cv_have_func_attribute_destructor" != "1"; then
+ AC_MSG_ERROR([*** Function destructor attribute is not supported by your compiler.])
+fi
AST_GCC_ATTRIBUTE(noreturn,noreturn)
AC_MSG_CHECKING(for -fsanitize=address support)