summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJoshua Colp <jcolp@digium.com>2007-08-01 19:37:59 +0000
committerJoshua Colp <jcolp@digium.com>2007-08-01 19:37:59 +0000
commit1e4bd7a192e513507ed864488dc90ab5de8060df (patch)
tree6d5a9eef20c02cf9420917da3379de99d344b8a6 /configure.ac
parenta7aaa0bbc2ba755d2a0ba13870044d4a9e1a7735 (diff)
Instead of adding the SOLARIS check to each HAVE_SYSINFO check let's just make the sysinfo autoconf logic a bit pickier about what it considers a usable sysinfo.
git-svn-id: https://origsvn.digium.com/svn/asterisk/trunk@77878 65c4cc65-6c06-0410-ace0-fbb531ad65f3
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index c32eb54a2..cb6bc26b6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -382,7 +382,7 @@ AC_SUBST(AST_DECLARATION_AFTER_STATEMENT)
AC_MSG_CHECKING(for sysinfo)
AC_LINK_IFELSE(
AC_LANG_PROGRAM([#include <sys/sysinfo.h>],
- [struct sysinfo sys_info;]),
+ [struct sysinfo sys_info; int uptime = sys_info.uptime]),
AC_MSG_RESULT(yes)
AC_DEFINE([HAVE_SYSINFO], 1, [Define to 1 if your system has sysinfo support]),
AC_MSG_RESULT(no)