summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKevin P. Fleming <kpfleming@digium.com>2009-06-16 19:27:12 +0000
committerKevin P. Fleming <kpfleming@digium.com>2009-06-16 19:27:12 +0000
commit4a93d3bcb5a24b8478dca20da8f55f6c546cb8b4 (patch)
treebcbbe603f0cf52dd4ae9ace74eb0cfa418f7106b /configure.ac
parent4c0265664ef7cf65a193486bd29b09ee80532f25 (diff)
Another minor fix to compiler attribute checking.
Defaulting to 'static' for the function scope was bad... so remove it. git-svn-id: https://origsvn.digium.com/svn/asterisk/trunk@201090 65c4cc65-6c06-0410-ace0-fbb531ad65f3
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index de7892fc1..cfb53fd7f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -515,7 +515,7 @@ AST_GCC_ATTRIBUTE(deprecated)
AST_GCC_ATTRIBUTE(sentinel)
AST_GCC_ATTRIBUTE(warn_unused_result)
AST_GCC_ATTRIBUTE(weakref, [weakref("foo")])
-AST_GCC_ATTRIBUTE(weak_import, , "")
+AST_GCC_ATTRIBUTE(weak_import)
AC_MSG_CHECKING(for -ffunction-sections support)
saved_CFLAGS="${CFLAGS}"