summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSean Bright <sean@malleable.com>2008-11-19 00:27:45 +0000
committerSean Bright <sean@malleable.com>2008-11-19 00:27:45 +0000
commit559e644b63ad59df5edb96ff233dba57b9d4ac47 (patch)
treeb0ee467816e3bb82d1ffd85c5ba5acf98af93bff /configure.ac
parenta361f7897a5d2a0038f3da9e8403b825d5c9f644 (diff)
Fix a few build problems on Solaris (and check for an md5 utility in
configure instead of the icky loop I was doing before). (closes issue #13842) Reported by: snuffy Patches: bug13842_20081106.diff uploaded by snuffy (license 35) 13842.diff uploaded by seanbright (license 71) Tested by: snuffy git-svn-id: https://origsvn.digium.com/svn/asterisk/trunk@157600 65c4cc65-6c06-0410-ace0-fbb531ad65f3
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 596424143..7e93cde84 100644
--- a/configure.ac
+++ b/configure.ac
@@ -190,6 +190,12 @@ if test "${SOXMIX}" != ":" ; then
AC_DEFINE([HAVE_SOXMIX], 1, [Define to 1 if your system has soxmix application.])
fi
+AC_CHECK_PROGS([MD5], [md5 md5sum gmd5sum digest])
+
+if test "${MD5}" = "digest" ; then
+ MD5="${MD5} -a md5"
+fi
+
ACX_PTHREAD
AC_LANG(C)