summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorzuul <zuul@gerrit.asterisk.org>2016-09-07 14:04:26 -0500
committerGerrit Code Review <gerrit2@gerrit.digium.api>2016-09-07 14:04:26 -0500
commit892536729188c29aecb6b2b5a6bab8928a63f530 (patch)
tree56c258d7f982dd3b7f96a4a19cb926fc03cdf7fc /configure.ac
parent4b66c74c9422c10c25dd42c7d204c5f499749d80 (diff)
parent9bca89546992a540d106a725734e6038cb91d76f (diff)
Merge "res_pjsip_session: segfault on already disconnected session" into 13
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5747396b4..1ba86bb7b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -502,6 +502,7 @@ AST_EXT_LIB_SETUP_OPTIONAL([PJ_SSL_CERT_LOAD_FROM_FILES2], [pj_ssl_cert_load_fro
AST_EXT_LIB_SETUP_OPTIONAL([PJSIP_EXTERNAL_RESOLVER], [PJSIP External Resolver Support], [PJPROJECT], [pjsip])
AST_EXT_LIB_SETUP_OPTIONAL([PJSIP_TLS_TRANSPORT_PROTO], [PJSIP TLS Transport proto field support], [PJPROJECT], [pjsip])
AST_EXT_LIB_SETUP_OPTIONAL([PJSIP_EVSUB_GRP_LOCK], [PJSIP EVSUB Group Lock support], [PJPROJECT], [pjsip])
+AST_EXT_LIB_SETUP_OPTIONAL([PJSIP_INV_SESSION_REF], [PJSIP INVITE Session Reference Count support], [PJPROJECT], [pjsip])
AST_EXT_LIB_SETUP([POPT], [popt], [popt])
AST_EXT_LIB_SETUP([PORTAUDIO], [PortAudio], [portaudio])
@@ -2206,6 +2207,7 @@ if test "$USE_PJPROJECT" != "no" ; then
CPPFLAGS="${saved_cppflags}"
AST_EXT_LIB_CHECK([PJSIP_EVSUB_GRP_LOCK], [pjsip], [pjsip_evsub_add_ref], [pjsip.h], [$PJPROJECT_LIB], [$PJPROJECT_CFLAGS])
+ AST_EXT_LIB_CHECK([PJSIP_INV_SESSION_REF], [pjsip], [pjsip_inv_add_ref], [pjsip.h], [$PJPROJECT_LIB], [$PJPROJECT_CFLAGS])
fi
fi