summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTilghman Lesher <tilghman@meg.abyt.es>2007-07-08 21:01:28 +0000
committerTilghman Lesher <tilghman@meg.abyt.es>2007-07-08 21:01:28 +0000
commit935bd057f87a4eed4637f28703834aec4d98f730 (patch)
treee26097b2e32f70833c0f6cdbc88889414c2b31f0 /configure.ac
parentcf6ee48b5b27d8a6e8beb7c729639318bd2c3b47 (diff)
Restore EXP2 and LOG2 functions, by providing mathematical identify functions, when the underlying C functions are not available.
git-svn-id: https://origsvn.digium.com/svn/asterisk/trunk@73911 65c4cc65-6c06-0410-ace0-fbb531ad65f3
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d223ca179..f7b04dec2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -375,8 +375,14 @@ if test "x${host_os}" = "xlinux-gnu" ; then
fi
# BSD might not have exp2, and/or log2
+AST_EXT_LIB_CHECK([EXP2L], [m], [exp2l])
+AST_EXT_LIB_CHECK([LOG2L], [m], [log2l])
+AST_EXT_LIB_CHECK([EXP10L], [m], [exp10l])
+AST_EXT_LIB_CHECK([LOG10L], [m], [log10l])
AST_EXT_LIB_CHECK([EXP2], [m], [exp2])
AST_EXT_LIB_CHECK([LOG2], [m], [log2])
+AST_EXT_LIB_CHECK([EXP10], [m], [exp10])
+AST_EXT_LIB_CHECK([LOG10], [m], [log10])
GSM_INTERNAL="yes"
AC_SUBST(GSM_INTERNAL)