summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTilghman Lesher <tilghman@meg.abyt.es>2009-02-03 00:29:49 +0000
committerTilghman Lesher <tilghman@meg.abyt.es>2009-02-03 00:29:49 +0000
commite179e613f7c291fc09102b23498e8bd128f79aeb (patch)
treec079f69e8eb11a6b8f496256b795b31c9773d773 /configure.ac
parent673d85387a2cef9534007f13ba2d9cd770eaba1d (diff)
1. Make OS X compile cleanly with app_stack.
2. Use curl to download sound files, as curl is installed natively on OS X, whereas wget and fetch are not. (closes issue #14332) Reported by: oej Tested by: Corydon76 git-svn-id: https://origsvn.digium.com/svn/asterisk/trunk@173130 65c4cc65-6c06-0410-ace0-fbb531ad65f3
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index bbfb999ca..bf30136f5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -174,15 +174,19 @@ AC_PATH_PROG([SHELL], [sh], :)
AC_PATH_PROG([LN], [ln], :)
AC_PATH_PROG([DOT], [dot], :)
AC_PATH_PROG([WGET], [wget], :)
+AC_PATH_PROG([CURL], [curl], :)
AC_PATH_PROG([RUBBER], [rubber], :)
AC_PATH_PROG([KPATHSEA], [kpsewhich], :)
AC_PATH_PROG([XMLSTARLET], [xmlstarlet], :)
if test "${WGET}" != ":" ; then
DOWNLOAD=${WGET}
+else if test "${CURL}" != ":" ; then
+ DOWNLOAD="${CURL} -O --progress-bar -w \"%{url_effective}\n\""
else
AC_PATH_PROG([FETCH], [fetch], [:])
DOWNLOAD=${FETCH}
fi
+fi
AC_SUBST(DOWNLOAD)
AC_CHECK_TOOL([SOXMIX], [soxmix], [:])
@@ -481,6 +485,7 @@ AST_GCC_ATTRIBUTE(deprecated)
AST_GCC_ATTRIBUTE(sentinel)
AST_GCC_ATTRIBUTE(warn_unused_result)
AST_GCC_ATTRIBUTE(weak)
+AST_GCC_ATTRIBUTE(weak_import)
AST_GCC_ATTRIBUTE(alias, [alias("foo")])
AC_MSG_CHECKING(for -ffunction-sections support)