summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJason Parker <jparker@digium.com>2006-09-18 23:59:23 +0000
committerJason Parker <jparker@digium.com>2006-09-18 23:59:23 +0000
commite3f0ca05e5a8934952ed2ad0437a64cb41c653d4 (patch)
treed7fed805868cbb9500e7ddc7978cfa89bb93d52a /configure.ac
parent3334bdebb702429a600b152d9b87db3c70a3e106 (diff)
This totally worked when I tested it...
Reverting for now.. git-svn-id: https://origsvn.digium.com/svn/asterisk/trunk@43245 65c4cc65-6c06-0410-ace0-fbb531ad65f3
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 14 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index c5988b406..f6c066802 100644
--- a/configure.ac
+++ b/configure.ac
@@ -960,11 +960,20 @@ PBX_CURL=0
AC_PATH_TOOL([CURL], [curl-config], No)
if test ! x"${CURL}" = xNo; then
# check for version
- if test 0x`curl-config --vernum` -ge 0x70907 ; then
- CURL_INCLUDE=$(${CURL} --cflags)
- CURL_LIB=$(${CURL} --libs)
- PBX_CURL=1
- AC_DEFINE([HAVE_CURL], 1, [Define if your system has the curl libraries.])
+ if test "${host_os}" = "SunOS"; then
+ if [[ 0x`curl-config --vernum` -ge 0x70907 ]]; then
+ CURL_INCLUDE=$(${CURL} --cflags)
+ CURL_LIB=$(${CURL} --libs)
+ PBX_CURL=1
+ AC_DEFINE([HAVE_CURL], 1, [Define if your system has the curl libraries.])
+ fi
+ else
+ if [[[ 0x`curl-config --vernum` -ge 0x70907 ]]]; then
+ CURL_INCLUDE=$(${CURL} --cflags)
+ CURL_LIB=$(${CURL} --libs)
+ PBX_CURL=1
+ AC_DEFINE([HAVE_CURL], 1, [Define if your system has the curl libraries.])
+ fi
fi
fi
AC_SUBST(PBX_CURL)