summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLuigi Rizzo <rizzo@icir.org>2007-12-19 08:57:45 +0000
committerLuigi Rizzo <rizzo@icir.org>2007-12-19 08:57:45 +0000
commitea8af9b995b2693976398c58f4ee08f6d6bd4d94 (patch)
tree981366afb69df784144abb0841da4b2b20a43977 /configure.ac
parent1d6b192ce0262db43b91bf736f15cd2d7f39082a (diff)
Properly document AST_EXT_TOOL_CHECK() and use it to check for
NETSMP and GTK (GTK is not used thoug). AST_EXT_TOOL_CHECK() could be used for checking curl status as well, perhaps with a small addition because we currently seem to require a curl version greater than X.Y.Z Add a NETSMP_INCLUDE entry in makeopts.in We don't have yet any macros for using pkg-config to check for a specific package (right now there is only gtk2+ in the category). git-svn-id: https://origsvn.digium.com/svn/asterisk/trunk@93898 65c4cc65-6c06-0410-ace0-fbb531ad65f3
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac52
1 files changed, 13 insertions, 39 deletions
diff --git a/configure.ac b/configure.ac
index 8b41545b4..cb521f5f7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -183,7 +183,13 @@ AC_ARG_ENABLE(dev-mode,
esac])
AC_SUBST(AST_DEVMODE)
-# package option names should be in alphabetical order
+# AST_EXT_LIB_SETUP is used to tell configure to handle variables for
+# various packages.
+# $1 is the prefix for the variables in makeopts and autoconfig.h
+# $2 is the short comment, $4 is the long comment
+# $3 is the name used in --with- or --without- flags for configure.
+#
+# Package option names should be in alphabetical order
# by the --with option name (the third field),
# to make things easier for the users.
@@ -197,6 +203,8 @@ AST_EXT_LIB_SETUP([CURL], [cURL], [curl])
AST_EXT_LIB_SETUP([CURSES], [curses], [curses])
AST_EXT_LIB_SETUP([CRYPTO], [OpenSSL Cryptography support], [crypto])
AST_EXT_LIB_SETUP([GSM], [External GSM library], [gsm], [, use 'internal' GSM otherwise])
+AST_EXT_LIB_SETUP([GTK], [gtk libraries], [gtk])
+AST_EXT_LIB_SETUP([GTK2], [gtk2 libraries], [gtk2])
AST_EXT_LIB_SETUP([IKSEMEL], [Iksemel Jabber Library], [iksemel])
AST_EXT_LIB_SETUP([IMAP_TK], [UW IMAP Toolkit], [imap])
AST_EXT_LIB_SETUP([ISDNNET], [ISDN4Linux Library], [isdnnet])
@@ -835,33 +843,8 @@ AST_EXT_LIB_CHECK([NBS], [nbs], [nbs_connect], [nbs.h])
AST_EXT_LIB_CHECK([NCURSES], [ncurses], [initscr], [curses.h])
-NETSNMP_CONFIG=No
-if test "${USE_NETSNMP}" != "no"; then
- if test "x${NETSNMP_DIR}" != "x"; then
- AC_PATH_TOOL([NETSNMP_CONFIG], [net-snmp-config], No, [${NETSNMP_DIR}/bin])
- if test x"${NETSNMP_CONFIG}" = xNo; then
- AC_MSG_NOTICE([***])
- AC_MSG_NOTICE([*** net-snmp-config was not found in the path you specified:])
- AC_MSG_NOTICE([*** ${NETSNMP_DIR}/bin])
- AC_MSG_NOTICE([*** Either correct the installation, or run configure])
- AC_MSG_NOTICE([*** including --without-netsnmp])
- exit 1
- fi
- else
- AC_PATH_TOOL([NETSNMP_CONFIG], [net-snmp-config], No)
- fi
-fi
-if test x"${NETSNMP_CONFIG}" != xNo; then
- NETSNMP_libs=`${NETSNMP_CONFIG} --agent-libs`
-
- AC_CHECK_LIB([netsnmp], [snmp_register_callback], AC_DEFINE_UNQUOTED([HAVE_NETSNMP], 1,
- [Define to indicate the Net-SNMP library]), [], ${NETSNMP_libs})
-
- if test "${ac_cv_lib_netsnmp_snmp_register_callback}" = "yes"; then
- NETSNMP_LIB="${NETSNMP_libs}"
- PBX_NETSNMP=1
- fi
-fi
+# XXX do we need to check for snmp_register_callback ?
+AST_EXT_TOOL_CHECK([NETSNMP], [net-snmp], , [--agent-libs])
AST_EXT_LIB_CHECK([NEWT], [newt], [newtBell], [newt.h])
@@ -1203,17 +1186,8 @@ AC_CHECK_HEADER([linux/videodev.h],
AST_EXT_LIB_CHECK([X11], [X11], [XOpenDisplay], [X11/Xlib.h],,, [standard_path])
AST_EXT_LIB_CHECK([X11], [X11], [XOpenDisplay], [X11/Xlib.h],, [-I/usr/X11R6/include], [X11R6])
-PBX_GTK=0
-AC_CHECK_TOOL(GTKCONFIG, gtk-config, No)
-if test ! "x${GTKCONFIG}" = xNo; then
- GTK_INCLUDE=$(${GTKCONFIG} --cflags gthread)
- GTK_LIB=$(${GTKCONFIG} --libs gthread)
- PBX_GTK=1
- AC_DEFINE([HAVE_GTK], 1, [Define if your system has the GTK libraries.])
-fi
-AC_SUBST(PBX_GTK)
-AC_SUBST(GTK_INCLUDE)
-AC_SUBST(GTK_LIB)
+# we don't use gtk right now...
+AST_EXT_TOOL_CHECK([GTK], [gtk])
PBX_GTK2=0
AC_CHECK_TOOL(PKGCONFIG, pkg-config, No)