summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthew Jordan <mjordan@digium.com>2014-07-17 19:02:22 +0000
committerMatthew Jordan <mjordan@digium.com>2014-07-17 19:02:22 +0000
commit26c7e684eaffe2c7f08219984147b23f66c7dca5 (patch)
treea52a5e9c8304aaa182d5ee194110aa45bdc3057b /configure.ac
parent62f5e26d354f49a7359bc242c1dd1a9661175b09 (diff)
menuselect: Add libxml2 support (Patch 3)
This is the final patch in adding menuselect to Asterisk. - The first patch (r418832) added menuselect along with mxml - The second patch (r418833) removed mxml from menuselect This patch adds support for libxml2 to menuselect, and makes libxml2 a required library for Asterisk. Note that the libxml2 portion of this patch was written by Sean Bright, and was made available on a team branch: http://svn.digium.com/svn/menuselect/team/seanbright/libxml2/ Review: https://reviewboard.asterisk.org/r/3773/ ASTERISK-20703 #close patches: some_mysterious_team_branch uploaded by seanbright (License 5060) git-svn-id: https://origsvn.digium.com/svn/asterisk/trunk@418834 65c4cc65-6c06-0410-ace0-fbb531ad65f3
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 6 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 7b21a2bd8..017f0d7c9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -550,6 +550,12 @@ if test "x$JANSSON_LIB" == "x"; then
AC_MSG_ERROR([*** JSON support not found (this typically means the libjansson development package is missing)])
fi
+if test "x$PBX_LIBXML2" == "x"; then
+ AC_MSG_NOTICE(*** The Asterisk menuselect tool requires the 'libxml2' package.)
+ AC_MSG_NOTICE(*** Please install the 'libxml2' package.)
+ exit 1
+fi
+
AST_EXT_LIB_CHECK([URIPARSER], [uriparser], [uriParseUriA], [uriparser/Uri.h])
# Another mandatory item (unless it's explicitly disabled)
@@ -567,13 +573,6 @@ if test "${disable_xmldoc}" != "yes"; then
[#include <libxml/tree.h>
#include <libxml/parser.h>],
[LIBXML_TEST_VERSION])
- if test "${PBX_LIBXML2}" != 1; then
- AC_MSG_NOTICE(*** XML documentation will not be available because the 'libxml2' development package is missing.)
- AC_MSG_NOTICE(*** Please run the 'configure' script with the '--disable-xmldoc' parameter option)
- AC_MSG_NOTICE(*** or install the 'libxml2' development package.)
- exit 1
- fi
-
AST_EXT_LIB_CHECK([LIBXSLT], [xslt], [xsltLoadStylesheetPI], [libxslt/xsltInternals.h], [${LIBXML2_LIB}], [${LIBXML2_INCLUDE}])
AST_EXT_LIB_CHECK([LIBXSLT_CLEANUP], [xslt], [xsltCleanupGlobals], [libxslt/xsltInternals.h], [${LIBXML2_LIB}], [${LIBXML2_INCLUDE}])