summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTilghman Lesher <tilghman@meg.abyt.es>2007-11-06 15:01:56 +0000
committerTilghman Lesher <tilghman@meg.abyt.es>2007-11-06 15:01:56 +0000
commit32701f5031f1365ad5df3e4da12c807057cf14fc (patch)
tree3b3fce2588cb1468cd30a3e71197f961f4ec5fc7 /configure.ac
parentca33f1e3646f9ca0953fe77c7c233cb06219308a (diff)
Set up detection of IP_PKTINFO in autoconf for chan_unistim
git-svn-id: https://origsvn.digium.com/svn/asterisk/trunk@88973 65c4cc65-6c06-0410-ace0-fbb531ad65f3
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f25847f68..dbe6094b6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -284,6 +284,15 @@ AC_CHECK_FUNCS([asprintf atexit bzero dup2 endpwent ftruncate getcwd gethostbyna
# fopencookie on linux
AC_CHECK_FUNCS([funopen fopencookie])
+# check if we have IP_PKTINFO constant defined
+AC_LINK_IFELSE(
+ AC_LANG_PROGRAM([#include <netinet/in.h>],
+ [int pi = IP_PKTINFO;]),
+ AC_MSG_RESULT(yes)
+ AC_DEFINE([HAVE_PKTINFO], 1, [Define to 1 if your system defines IP_PKTINFO.]),
+ AC_MSG_RESULT(no)
+)
+
# some systems already have gethostbyname_r so we don't need to build ours in main/utils.c
AC_SEARCH_LIBS(gethostbyname_r, [socket nsl])