summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTilghman Lesher <tilghman@meg.abyt.es>2010-06-08 22:45:16 +0000
committerTilghman Lesher <tilghman@meg.abyt.es>2010-06-08 22:45:16 +0000
commit3c26b511e03ac9dde860787f2cf3cf2ad06df495 (patch)
tree22560e41c6bd633476d35dbd1a35e10e4f808891 /configure.ac
parentf3a9392542c1b91fde8e9a2f38b6e43f253be109 (diff)
Fix build on Mac OS X (and maybe FreeBSD, too)
git-svn-id: https://origsvn.digium.com/svn/asterisk/trunk@269119 65c4cc65-6c06-0410-ace0-fbb531ad65f3
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4e09aa3f1..c588301de 100644
--- a/configure.ac
+++ b/configure.ac
@@ -550,6 +550,21 @@ then
AC_CHECK_FILE(/dev/urandom, AC_DEFINE([HAVE_DEV_URANDOM], 1, [Define to 1 if your system has /dev/urandom.]))
fi
+AC_MSG_CHECKING(for locale_t in locale.h)
+AC_LINK_IFELSE(
+AC_LANG_PROGRAM([#include <locale.h>], [locale_t lt = NULL]),
+AC_MSG_RESULT(yes)
+AC_DEFINE([HAVE_LOCALE_T_IN_LOCALE_H], 1, [Define to 1 if your system defines the locale_t type in locale.h]),
+AC_MSG_RESULT(no)
+ AC_MSG_CHECKING(for locale_t in xlocale.h)
+ AC_LINK_IFELSE(
+ AC_LANG_PROGRAM([#include <xlocale.h>], [locale_t lt = NULL]),
+ AC_MSG_RESULT(yes)
+ AC_DEFINE([HAVE_LOCALE_T_IN_XLOCALE_H], 1, [Define to 1 if your system defines the locale_t type in xlocale.h]),
+ AC_MSG_RESULT(no)
+ )
+)
+
AC_MSG_CHECKING(for O_EVTONLY in fcntl.h)
AC_LINK_IFELSE(
AC_LANG_PROGRAM([#include <fcntl.h>], [int a = O_EVTONLY;]),