summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthew Jordan <mjordan@digium.com>2014-07-17 19:31:05 +0000
committerMatthew Jordan <mjordan@digium.com>2014-07-17 19:31:05 +0000
commit3f64ca0c04f3b0482125d99c6b9566a406af48ed (patch)
tree621fd1361b167d88735a380c8a329dade3b8a335 /configure.ac
parent26c7e684eaffe2c7f08219984147b23f66c7dca5 (diff)
configure: Fix libxml2 development library dependency checking
The commit that added libxml2 support didn't fully check for the libxml2 development script in the Asterisk configure file. As a result, Asterisk could be configured, then fail on menuselect. This patch fixes it so that Asterisk should detect the libxml2 dependency failure first. git-svn-id: https://origsvn.digium.com/svn/asterisk/trunk@418850 65c4cc65-6c06-0410-ace0-fbb531ad65f3
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 8 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 017f0d7c9..0042dbf08 100644
--- a/configure.ac
+++ b/configure.ac
@@ -550,9 +550,14 @@ if test "x$JANSSON_LIB" == "x"; then
AC_MSG_ERROR([*** JSON support not found (this typically means the libjansson development package is missing)])
fi
-if test "x$PBX_LIBXML2" == "x"; then
- AC_MSG_NOTICE(*** The Asterisk menuselect tool requires the 'libxml2' package.)
- AC_MSG_NOTICE(*** Please install the 'libxml2' package.)
+AST_EXT_TOOL_CHECK([LIBXML2], [xml2-config], , ,
+ [#include <libxml/tree.h>
+ #include <libxml/parser.h>],
+ [LIBXML_TEST_VERSION])
+
+if test "${PBX_LIBXML2}" != 1; then
+ AC_MSG_NOTICE(*** The Asterisk menuselect tool requires the 'libxml2' development package.)
+ AC_MSG_NOTICE(*** Please install the 'libxml2' development package.)
exit 1
fi
@@ -569,10 +574,6 @@ AC_ARG_ENABLE([xmldoc],
esac], [disable_xmldoc=no])
if test "${disable_xmldoc}" != "yes"; then
- AST_EXT_TOOL_CHECK([LIBXML2], [xml2-config], , ,
- [#include <libxml/tree.h>
- #include <libxml/parser.h>],
- [LIBXML_TEST_VERSION])
AST_EXT_LIB_CHECK([LIBXSLT], [xslt], [xsltLoadStylesheetPI], [libxslt/xsltInternals.h], [${LIBXML2_LIB}], [${LIBXML2_INCLUDE}])
AST_EXT_LIB_CHECK([LIBXSLT_CLEANUP], [xslt], [xsltCleanupGlobals], [libxslt/xsltInternals.h], [${LIBXML2_LIB}], [${LIBXML2_INCLUDE}])