summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSean Bright <sean@malleable.com>2014-07-21 14:49:43 +0000
committerSean Bright <sean@malleable.com>2014-07-21 14:49:43 +0000
commit7677d564e779bf95268fb7c8a5523a6514c21f69 (patch)
treeb08f31f0de49baccd35b05dfeaf4361e21e23836 /configure.ac
parente04607f8a327363aed79e794bd5dc1cdbb9a54e8 (diff)
Fix build when pjproject is installed in a non-standard location.
When configuring Asterisk to build against a version of pjproject installed in a non-standard location, the checks for "PJSIP Transaction Group Lock Support" and "PJSIP Media Stream Replacement Support" fail. This is because these secondary checks are not taking the CFLAGS and LIBS returned by the pkg-config check into account. Review: https://reviewboard.asterisk.org/r/3830 git-svn-id: https://origsvn.digium.com/svn/asterisk/trunk@419077 65c4cc65-6c06-0410-ace0-fbb531ad65f3
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 0042dbf08..c97bcabeb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2041,9 +2041,15 @@ fi
AST_PKG_CONFIG_CHECK([PJPROJECT], [libpjproject])
-AST_EXT_LIB_CHECK([PJ_TRANSACTION_GRP_LOCK], [pjsip], [pjsip_tsx_create_uac2], [pjsip.h])
+AST_EXT_LIB_CHECK([PJ_TRANSACTION_GRP_LOCK], [pjsip], [pjsip_tsx_create_uac2], [pjsip.h], [$PJPROJECT_LIBS], [$PJPROJECT_CFLAGS])
+saved_cppflags="${CPPFLAGS}"
+saved_libs="${LIBS}"
+CPPFLAGS="${CPPFLAGS} ${PJPROJECT_CFLAGS}"
+LIBS="${LIBS} ${PJPROJECT_LIBS}"
AST_C_COMPILE_CHECK([PJSIP_REPLACE_MEDIA_STREAM], [pjmedia_mod_offer_flag flag = PJMEDIA_SDP_NEG_ALLOW_MEDIA_CHANGE], [pjmedia.h])
+LIBS="${saved_libs}"
+CPPFLAGS="${saved_cppflags}"
AST_EXT_LIB_CHECK([POPT], [popt], [poptStrerror], [popt.h])