summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLuigi Rizzo <rizzo@icir.org>2007-11-17 00:31:32 +0000
committerLuigi Rizzo <rizzo@icir.org>2007-11-17 00:31:32 +0000
commitd209cb090e23d03c88bdb3ad95061d6abbabc0d2 (patch)
treeeec48aac560a463317bda9b584ae098768ddd9fb /configure.ac
parentd82a631f9c7e5de1d63c0627722a2277a348837d (diff)
add check for the presence of glob
git-svn-id: https://origsvn.digium.com/svn/asterisk/trunk@89350 65c4cc65-6c06-0410-ace0-fbb531ad65f3
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index dbe6094b6..6d7c0e33f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -86,7 +86,7 @@ case "${host_os}" in
OSARCH=SunOS
;;
*)
- OSARCH=${HOST_OS}
+ OSARCH=${host_os}
;;
esac
@@ -280,6 +280,8 @@ AC_FUNC_UTIME_NULL
AC_FUNC_VPRINTF
AC_CHECK_FUNCS([asprintf atexit bzero dup2 endpwent ftruncate getcwd gethostbyname gethostname getloadavg gettimeofday inet_ntoa isascii localtime_r memchr memmove memset mkdir munmap putenv re_comp regcomp select setenv socket strcasecmp strcasestr strchr strcspn strdup strerror strlcat strlcpy strncasecmp strndup strnlen strrchr strsep strspn strstr strtol strtoq unsetenv utime vasprintf])
+AC_CHECK_FUNCS([glob])
+
# https support (in main/http.c) uses funopen on BSD systems,
# fopencookie on linux
AC_CHECK_FUNCS([funopen fopencookie])
@@ -1240,6 +1242,8 @@ fi
AC_MSG_NOTICE(Package configured for: )
AC_MSG_NOTICE( OS type : $host_os)
AC_MSG_NOTICE( Host CPU : $host_cpu)
+AC_MSG_NOTICE( build-cpu:vendor:os: $build_cpu : $build_vendor : $build_os :)
+AC_MSG_NOTICE( host-cpu:vendor:os: $host_cpu : $host_vendor : $host_os :)
if test "${cross_compiling}" = "yes"; then
AC_MSG_NOTICE( Cross Compilation = YES)
fi