summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRussell Bryant <russell@russellbryant.com>2007-06-04 16:03:19 +0000
committerRussell Bryant <russell@russellbryant.com>2007-06-04 16:03:19 +0000
commitbecbe90833dfd77da02dfaa559943df09056af2a (patch)
treefd2e6bb534a6649533751d086ce791935c8bd393 /configure.ac
parente1375b96c286cbb4cfedceb1f5ef8d19b95711cf (diff)
Merged revisions 67026 via svnmerge from
https://origsvn.digium.com/svn/asterisk/branches/1.4 ........ r67026 | russell | 2007-06-04 11:02:31 -0500 (Mon, 04 Jun 2007) | 6 lines Change the configure script to build a test program against libcurl to make sure the results from curl-config can be used to compile successfully. This is intended to help prevent a situation where you are cross compiling, and the configure script finds the curl library installed on the host. (issue #9865, reported and patched by zandbelt) ........ git-svn-id: https://origsvn.digium.com/svn/asterisk/trunk@67029 65c4cc65-6c06-0410-ace0-fbb531ad65f3
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 21 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 22206d4f6..9d0a628c5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1016,8 +1016,27 @@ if test "${USE_CURL}" != "no"; then
if test $(printf "%d" 0x$(${CURL_CONFIG} --vernum)) -ge $(printf "%d" 0x070907); then
CURL_INCLUDE=$(${CURL_CONFIG} --cflags)
CURL_LIB=$(${CURL_CONFIG} --libs)
- PBX_CURL=1
- AC_DEFINE([HAVE_CURL], 1, [Define if your system has the curl libraries.])
+
+ AC_MSG_CHECKING(for curl_version() in curl/curl.h)
+ saved_cppflags="${CPPFLAGS}"
+ CPPFLAGS="${CPPFLAGS} ${CURL_INCLUDE}"
+ AC_COMPILE_IFELSE(
+ [AC_LANG_PROGRAM(
+ [#include <curl/curl.h>],
+ [curl_version();])
+ ],[
+ AC_MSG_RESULT(yes)
+ ac_cv_curl_h="yes"
+ ],[
+ AC_MSG_RESULT(no)
+ ac_cv_curl_h="no"
+ ]
+ )
+ CPPFLAGS="${saved_cppflags}"
+ if test "${ac_cv_curl_h}" = "yes"; then
+ PBX_CURL=1
+ AC_DEFINE([HAVE_CURL], 1, [Define if your system has the curl libraries.])
+ fi
fi
fi
fi