summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatt Jordan <mjordan@digium.com>2016-05-11 14:07:17 -0500
committerMatt Jordan <mjordan@digium.com>2016-05-11 14:07:17 -0500
commit37214b0bdf52cf2f742349b22fae73742aeda091 (patch)
treec4347870ea94e0dab8e6fde9317c6127b86fc8e4 /configure.ac
parenta01ce2b88912cd802bb045e40fe264906e55bc45 (diff)
configure: Fix errors with AST_UNDEFINED_SANITIZER/AST_LEAK_SANITIZER
When running on a system that does not support or use AST_UNDEFINED_SANITIZER or AST_LEAK_SANITIZER, the configure script would incorrectly set those constants to a blank value, e.g., 'AST_UNDEFINED_SANITIZER='. This would cause menuselect to error out, complaining that a blank value is not a valid option. This patch corrects the issue by setting the value to 0 if the options that those constants enable/disable is not found. Change-Id: Ib39814aaf940f308d500c1e026edb3d70de47fba
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 822303708..f2e42ba1f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1116,7 +1116,7 @@ AC_COMPILE_IFELSE(
[AC_LANG_PROGRAM([], [int x = 1;])],
AC_MSG_RESULT(yes)
[AST_LEAK_SANITIZER=1],
- [AST_LEAK_SANITIZER=]
+ [AST_LEAK_SANITIZER=0]
AC_MSG_RESULT(no)
)
CFLAGS="${saved_sanitize_CFLAGS}"
@@ -1132,7 +1132,7 @@ AC_COMPILE_IFELSE(
[AC_LANG_PROGRAM([], [int x = 1;])],
AC_MSG_RESULT(yes)
[AST_UNDEFINED_SANITIZER=1],
- [AST_UNDEFINED_SANITIZER=]
+ [AST_UNDEFINED_SANITIZER=0]
AC_MSG_RESULT(no)
)
CFLAGS="${saved_sanitize_CFLAGS}"