summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWalter Doekes <walter+asterisk@wjd.nu>2013-01-19 20:54:07 +0000
committerWalter Doekes <walter+asterisk@wjd.nu>2013-01-19 20:54:07 +0000
commite6a3674150b01d2126b4a653cd10ea1ab6f3b09d (patch)
tree9f61ebbb55b1bfbe769dbf5c1ed86fc25752ffa6 /configure.ac
parent01763fd41b1325f56d727023b8a92697f272f285 (diff)
Add builtin roundf() for systems lacking it.
(closes issue ASTERISK-16854) Review: https://reviewboard.asterisk.org/r/2276 Reported-by: Ovidiu Sas ........ Merged revisions 379547 from http://svn.asterisk.org/svn/asterisk/branches/1.8 ........ Merged revisions 379548 from http://svn.asterisk.org/svn/asterisk/branches/11 git-svn-id: https://origsvn.digium.com/svn/asterisk/trunk@379549 65c4cc65-6c06-0410-ace0-fbb531ad65f3
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index e90682754..c495b4e0e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -597,7 +597,7 @@ AC_CHECK_FUNCS([asprintf atexit closefrom dup2 eaccess endpwent euidaccess ffsll
# so that AC_CHECK_FUNCS can detect functions in that library.
AC_CHECK_LIB([m], [sqrt])
# BSD might not have exp2, and/or log2
-AC_CHECK_FUNCS([exp2 log2 exp10 log10 sin cos tan asin acos atan atan2 pow rint exp log remainder fmod round trunc floor ceil])
+AC_CHECK_FUNCS([exp2 log2 exp10 log10 sin cos tan asin acos atan atan2 pow rint exp log remainder fmod round roundf trunc floor ceil])
# Certain architectures don't really have long double, even though
# AC_CHECK_FUNCS would otherwise find the following functions.