summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSean Bright <sean.bright@gmail.com>2017-03-24 08:43:05 -0400
committerCorey Farrell <git@cfware.com>2017-03-27 10:36:15 -0400
commitb033b74118d6c65b495a70556c22ade55d1ec39a (patch)
tree3b74d9857678a4bbe864b0d8de711cdcfd40e95f /configure.ac
parent3e2cd7c5932399fe6ebcf73e324dc59a171fbe72 (diff)
core: Remove embedded module support
This has not worked for some time and is no longer actively maintained. Change-Id: I5110b0db69c152761b58fa025cb0a53b0e544d99
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 0 insertions, 23 deletions
diff --git a/configure.ac b/configure.ac
index d9a800ae2..f0e848ede 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1198,29 +1198,6 @@ CFLAGS="${saved_sanitize_CFLAGS}"
LDFLAGS="${saved_sanitize_LDFLAGS}"
AC_SUBST(AST_UNDEFINED_SANITIZER)
-AC_MSG_CHECKING(for -ffunction-sections support)
-saved_CFLAGS="${CFLAGS}"
-CFLAGS="${CFLAGS} -ffunction-sections"
-AC_COMPILE_IFELSE(
- [AC_LANG_PROGRAM([], [int x = 1;])],
- AC_MSG_RESULT(yes)
- [saved_LDFLAGS="${LDFLAGS}"]
- [LDFLAGS="${LDFLAGS} -Wl,--gc-sections"]
- AC_MSG_CHECKING(for --gc-sections support)
- AC_LINK_IFELSE(
- [AC_LANG_PROGRAM([], [int x = 1;])],
- AC_MSG_RESULT(yes)
- [GC_CFLAGS="-ffunction-sections"]
- [[GC_LDFLAGS="-Wl,--gc-sections"]],
- AC_MSG_RESULT(no)
- )
- [LDFLAGS="${saved_LDFLAGS}"],
- AC_MSG_RESULT(no)
-)
-CFLAGS="${saved_CFLAGS}"
-AC_SUBST(GC_CFLAGS)
-AC_SUBST(GC_LDFLAGS)
-
AC_MSG_CHECKING(for -Wdeclaration-after-statement support)
if $(${CC} -Wdeclaration-after-statement -S -o /dev/null -xc /dev/null > /dev/null 2>&1); then
AC_MSG_RESULT(yes)