summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTilghman Lesher <tilghman@meg.abyt.es>2009-08-30 06:43:04 +0000
committerTilghman Lesher <tilghman@meg.abyt.es>2009-08-30 06:43:04 +0000
commit01fd08d5b9a3fba0975bbe3c0eec83c9e5ea684f (patch)
tree023ff5a3e3303a33a8141fba0e4ddc7a58b787fb /configure.ac
parent0689410e01bd086593dbe892e68f784b79e1685b (diff)
If lua is detected with the lua5.1 prefix (or not), adjust the include path accordingly.
Based upon feedback to a release announcement on the -users list. See http://lists.digium.com/pipermail/asterisk-users/2009-August/236954.html git-svn-id: https://origsvn.digium.com/svn/asterisk/trunk@214819 65c4cc65-6c06-0410-ace0-fbb531ad65f3
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c7ae196cf..b20410fd1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1494,6 +1494,10 @@ if test "${PBX_PWLIB}" = "1" -a "${USE_OPENH323}" != "no" ; then
fi
AST_EXT_LIB_CHECK([LUA], [lua5.1], [luaL_newstate], [lua5.1/lua.h], [-lm])
+if test "x${PBX_LUA}" = "x1" ; then
+ AC_DEFINE_UNQUOTED([LUA51_PREFIX], [1], [Define to 1 if lua is found with a lua5.1 prefix])
+fi
+
# Some distributions (like SuSE) remove the 5.1 suffix.
AST_EXT_LIB_CHECK([LUA], [lua], [luaL_register], [lua.h], [-lm])