summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRussell Bryant <russell@russellbryant.com>2006-05-09 10:43:08 +0000
committerRussell Bryant <russell@russellbryant.com>2006-05-09 10:43:08 +0000
commit10187179fb2d1fb2647534feb17eafbc45f00a95 (patch)
treeadc54829ba10d06c069c0118aaffb48725aea0ce /configure.ac
parent3135a35b92d9d7028a6fc2a7af58ad697cfe2f5d (diff)
change the check for zaptel to only check for linux/zaptel.h on Linux, and
zaptel.h otherwise If you did ./configure --with-tonezone=/usr/local/ on FreeBSD, it would run the first macro which would not find it, but it wouldn't make it to the second macro because the first check saw that --with-tonezone was specified and would exit with error git-svn-id: https://origsvn.digium.com/svn/asterisk/trunk@25989 65c4cc65-6c06-0410-ace0-fbb531ad65f3
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 4 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 88dacbf2b..e7e8821a7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -210,9 +210,10 @@ fi
AC_SUBST([PBX_LIBossaudio])
-AST_EXT_LIB([tonezone], [tone_zone_find], [linux/zaptel.h], [ZAPTEL], [Zaptel])
-if test "$PBX_LIBtonezone" = "0"; then
- AST_EXT_LIB([tonezone], [tone_zone_find], [zaptel.h], [ZAPTEL], [Zaptel], [-lm])
+if test "${PBX_OSTYPE}" = "Linux" ; then
+ AST_EXT_LIB([tonezone], [tone_zone_find], [linux/zaptel.h], [ZAPTEL], [Zaptel])
+else
+ AST_EXT_LIB([tonezone], [tone_zone_find], [zaptel.h], [ZAPTEL], [Zaptel], [-lm])
fi
GSM_INTERNAL="yes"