summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid M. Lee <dlee@respoke.io>2016-12-16 01:32:57 -0600
committerDavid M. Lee <dlee@digium.com>2016-12-16 01:36:04 -0600
commit147b8e636ef48a07891d4ce908a81f070ddf3437 (patch)
tree72cb66d60d6c75e8ed209f215ce90c5078e9001a /configure.ac
parent19328de2ab1317e75a7bf4cb6ebf9fce55cb05e1 (diff)
configure: fix with-pjproject-bundled
The AC_ARG_WITH macro's shell variable is withval; not enableval. Purely coincidentally, the option would work when --enable-dev-mode is given. Also fixed a portability problem with bootstrap.sh, since -printf is not a portable option for find. Change-Id: I0f0e5b1a934b5af5737713834361e9c95b96b376
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 161ccab5f..d604d47a5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -430,7 +430,7 @@ AH_TEMPLATE(m4_bpatsubst([[HAVE_PJPROJECT_BUNDLED]], [(.*)]), [Define to 1 when
AC_ARG_WITH([pjproject-bundled],
[AS_HELP_STRING([--with-pjproject-bundled],
[Use bundled pjproject libraries])],
- [case "${enableval}" in
+ [case "${withval}" in
n|no) PJPROJECT_BUNDLED=no ;;
*) PJPROJECT_BUNDLED=yes ;;
esac])