summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTilghman Lesher <tilghman@meg.abyt.es>2010-03-17 00:14:29 +0000
committerTilghman Lesher <tilghman@meg.abyt.es>2010-03-17 00:14:29 +0000
commit374e4e9d726ef6084180fdee7741f22b1efe60ce (patch)
tree111161c056abd36215537b8c7962d6d0d2dfad72 /configure.ac
parentae5a398322c6e2f7ac455cf577a0f3572db3e150 (diff)
Fix bamboo compile error by calculating an integer with the same size as a pointer.
git-svn-id: https://origsvn.digium.com/svn/asterisk/trunk@252980 65c4cc65-6c06-0410-ace0-fbb531ad65f3
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 5a4aac7fe..057327a09 100644
--- a/configure.ac
+++ b/configure.ac
@@ -780,7 +780,10 @@ AST_C_DEFINE_CHECK([IP_MTU_DISCOVER], [IP_MTU_DISCOVER], [netinet/in.h])
AC_CHECK_HEADER([libkern/OSAtomic.h],
[AC_DEFINE_UNQUOTED([HAVE_OSX_ATOMICS], 1, [Define to 1 if OSX atomic operations are supported.])])
-AC_CHECK_SIZEOF(int)
+AC_CHECK_SIZEOF([int])
+AC_CHECK_SIZEOF([long])
+AC_CHECK_SIZEOF([long long])
+AC_CHECK_SIZEOF([char *])
# do the package library checks now