summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRussell Bryant <russell@russellbryant.com>2007-11-17 06:33:07 +0000
committerRussell Bryant <russell@russellbryant.com>2007-11-17 06:33:07 +0000
commit505499588b17ed5397688ed10ea52c92318a8a59 (patch)
treed386269f08375e9b9476aff1b8a87ad8e8abd780 /configure.ac
parent89a49511a479330ed1a3b655766b44b4b29cabf5 (diff)
Update the configure script check for sys/poll.h to also provide the result in
include/asterisk/autoconfig.h. Also, move the conditional include of sys/poll.h or asterisk/poll-compat.h into asterisk/config.h instead of the two headers it existed in before. git-svn-id: https://origsvn.digium.com/svn/asterisk/trunk@89361 65c4cc65-6c06-0410-ace0-fbb531ad65f3
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 3a56fbecc..aa8966802 100644
--- a/configure.ac
+++ b/configure.ac
@@ -288,7 +288,10 @@ AC_CHECK_FUNCS([asprintf atexit bzero dup2 endpwent ftruncate getcwd gethostbyna
AC_CHECK_FUNCS([glob])
AC_CHECK_FUNCS([timersub])
-AC_CHECK_HEADER([sys/poll.h], [HAS_POLL=1],)
+AC_CHECK_HEADER([sys/poll.h],
+ [HAS_POLL=1]
+ AC_DEFINE([HAVE_SYS_POLL_H], 1, [Define to 1 if your system has working sys/poll.h]),
+ )
AC_SUBST(HAS_POLL)
# https support (in main/http.c) uses funopen on BSD systems,