summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatt Jordan <mjordan@digium.com>2017-03-14 15:12:28 -0500
committerMatt Jordan <mjordan@digium.com>2017-03-14 14:14:15 -0600
commit59130260e7bde0a0b69445b0b0ad7089387b890c (patch)
treed73db9eda7ef5174378bc434ad0c57253bb9cd68 /configure.ac
parent2b611a8d932a30a95675ac63bfd7c8ea2d3d8ad7 (diff)
configure: Don't use the progress bar with curl when downloading to stdout
In some scenarios, such as when there may not be a terminal (such as inside a Docker container), curl will apparently direct the progress bar to stdout. This can cause extra data to be appended to a file curl'd down to stdout, resulting in md5 verification failures. This patch removes the progress bar, and tells curl to download the file silently. ASTERISK-26872 #close Change-Id: Ie860b020f627d4372b3e7ce9453de5faafeebe6c
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index e714c54b6..890f32d47 100644
--- a/configure.ac
+++ b/configure.ac
@@ -318,7 +318,7 @@ if test "${WGET}" != ":" ; then
DOWNLOAD_TIMEOUT='--timeout=$1'
else if test "${CURL}" != ":" ; then
DOWNLOAD="${CURL} -O --progress-bar -w \"%{url_effective}\n\""
- DOWNLOAD_TO_STDOUT="${CURL} -L --progress-bar"
+ DOWNLOAD_TO_STDOUT="${CURL} -Ls"
DOWNLOAD_TIMEOUT='--max-time $(or $2,$1)'
else
AC_PATH_PROG([FETCH], [fetch], [:])