summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJenkins2 <jenkins2@gerrit.asterisk.org>2017-11-17 09:45:12 -0600
committerGerrit Code Review <gerrit2@gerrit.digium.api>2017-11-17 09:45:12 -0600
commit8fdc7fd1d3e77ae171671231e318d15710a0f715 (patch)
treef7403c6c6101de030f092102fc7bd9ec52c4100b /configure.ac
parent536e4a31b73c1cb9282008304a4b4a2cf10e66ee (diff)
parenta3a20e952829ada600b7f4f19fb5e865e9eef752 (diff)
Merge "Build: Make function constructor/destructor attributes mandatory." into 15
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 23ff5265a..f5c160c73 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1149,7 +1149,14 @@ AST_GCC_ATTRIBUTE(sentinel)
AST_GCC_ATTRIBUTE(warn_unused_result)
AST_GCC_ATTRIBUTE(may_alias)
AST_GCC_ATTRIBUTE(constructor)
+if test "$ax_cv_have_func_attribute_constructor" != "1"; then
+ AC_MSG_ERROR([*** Function constructor attribute is not supported by your compiler.])
+fi
+
AST_GCC_ATTRIBUTE(destructor)
+if test "$ax_cv_have_func_attribute_destructor" != "1"; then
+ AC_MSG_ERROR([*** Function destructor attribute is not supported by your compiler.])
+fi
AST_GCC_ATTRIBUTE(noreturn,noreturn)
AC_MSG_CHECKING(for -fsanitize=address support)