summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJoshua Colp <jcolp@digium.com>2017-06-14 11:07:04 -0500
committerGerrit Code Review <gerrit2@gerrit.digium.api>2017-06-14 11:07:04 -0500
commitc33168c14761a38ec8732dbcb6d3be2758a6571a (patch)
treeed391d217e1b04eca6bd673311c0805528f8dcec /configure.ac
parent42f738e0528252479496680925081a35b1172b7e (diff)
parentfcb1a0d7e803e033545fc721ab12a903603d302c (diff)
Merge "CFLAGS for BIND8 support"
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d7fb2171e..ecbe87093 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1361,6 +1361,18 @@ AC_LINK_IFELSE(
AC_MSG_RESULT(no)
)
+AC_MSG_CHECKING(for BIND_8_COMPAT required)
+AC_COMPILE_IFELSE([AC_LANG_PROGRAM(
+[[
+#undef BIND_8_COMPAT
+#include <arpa/nameser.h>
+]],
+[[int x = NXDOMAIN]])],
+AC_MSG_RESULT(no),
+AC_MSG_RESULT(yes)
+[BIND8_CFLAGS=-DBIND_8_COMPAT])
+AC_SUBST(BIND8_CFLAGS)
+
AST_C_DEFINE_CHECK([GLOB_NOMAGIC], [GLOB_NOMAGIC], [glob.h])
AST_C_DEFINE_CHECK([GLOB_BRACE], [GLOB_BRACE], [glob.h])