summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCorey Farrell <git@cfware.com>2017-03-30 10:51:14 -0400
committerCorey Farrell <git@cfware.com>2017-10-25 10:26:12 -0500
commitddcf98c0d378feca24936d2bf9aa7dd9f24f87ff (patch)
tree0be733a5966327b6a1bd33bebb31529afa295a5c /configure.ac
parentaa1c969942e9e209790e3e2093308e287595bffe (diff)
Build System: Fix --disable-xmldoc option.
The configure option to disable XML documentation does not currently work. This patch makes it effective, but also causes an ABI change by removing the ast_xmldoc_* symbols. Disabling xmldoc also prevents docs from being automatically generated, but they can still be manually generated with 'make doc/core-en_US.xml'. ASTERISK-26639 Change-Id: Ifac562340c09f80c83e0203de098fcac93bf8c44
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 6 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index c729b94ab..3fe904402 100644
--- a/configure.ac
+++ b/configure.ac
@@ -690,12 +690,14 @@ AC_ARG_ENABLE([xmldoc],
[AS_HELP_STRING([--disable-xmldoc],
[Explicitly disable XML documentation])],
[case "${enableval}" in
- y|ye|yes) disable_xmldoc=no ;;
- n|no) disable_xmldoc=yes ;;
+ y|ye|yes) DISABLE_XMLDOC=no ;;
+ n|no) DISABLE_XMLDOC=yes ;;
*) AC_MSG_ERROR(bad value ${enableval} for --disable-xmldoc) ;;
- esac], [disable_xmldoc=no])
+ esac], [DISABLE_XMLDOC=no])
-if test "${disable_xmldoc}" != "yes"; then
+AC_SUBST([DISABLE_XMLDOC])
+if test "${DISABLE_XMLDOC}" != "yes"; then
+ AC_DEFINE([AST_XML_DOCS], 1, [Define to enable XML documentation.])
AST_EXT_LIB_CHECK([LIBXSLT], [xslt], [xsltLoadStylesheetPI], [libxslt/xsltInternals.h], [${LIBXML2_LIB}], [${LIBXML2_INCLUDE}])
AST_EXT_LIB_CHECK([LIBXSLT_CLEANUP], [xslt], [xsltCleanupGlobals], [libxslt/xsltInternals.h], [${LIBXML2_LIB}], [${LIBXML2_INCLUDE}])