summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJoshua Colp <jcolp@digium.com>2007-08-01 18:56:31 +0000
committerJoshua Colp <jcolp@digium.com>2007-08-01 18:56:31 +0000
commite03296f7cbeb81014d16598c34336dd9f0d3f7d0 (patch)
tree2964917a1141d8c4d25927f561a073b183ea1a42 /configure.ac
parent54468c08740fb05cb8780d29bac347e79c6c73ef (diff)
Don't look for /dev/urandom when cross compiling. Just assume it is not available.
git-svn-id: https://origsvn.digium.com/svn/asterisk/trunk@77875 65c4cc65-6c06-0410-ace0-fbb531ad65f3
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index dd2e95d86..c32eb54a2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -322,7 +322,10 @@ AC_DEFINE([HAVE_SYS_ENDIAN_BSWAP16], 1, [Define to 1 if your sys/endian.h header
AC_MSG_RESULT(no)
)
-AC_CHECK_FILE(/dev/urandom, AC_DEFINE([HAVE_DEV_URANDOM], 1, [Define to 1 if your system has /dev/urandom.]))
+if test "${cross_compiling}" = "no";
+then
+ AC_CHECK_FILE(/dev/urandom, AC_DEFINE([HAVE_DEV_URANDOM], 1, [Define to 1 if your system has /dev/urandom.]))
+fi
AST_C_DEFINE_CHECK([PTHREAD_RWLOCK_INITIALIZER], [PTHREAD_RWLOCK_INITIALIZER], [pthread.h])
AST_C_DEFINE_CHECK([PTHREAD_RWLOCK_PREFER_WRITER_NP], [PTHREAD_RWLOCK_PREFER_WRITER_NP], [pthread.h])