summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTilghman Lesher <tilghman@meg.abyt.es>2010-07-15 18:44:20 +0000
committerTilghman Lesher <tilghman@meg.abyt.es>2010-07-15 18:44:20 +0000
commite2ff55122d36c1190599be67d8e0ffb306c231bd (patch)
tree48fba4a717ce778ac4c7602ce316d3752a48a12a /configure.ac
parente7591ab42811067c1038d2b18aa34063a64e1c50 (diff)
Fix linking asterisk on CentOS 5, which is using gcc 4.1.1. Gcc 4.1.2 has the real fix.
Review: https://reviewboard.asterisk.org/r/790/ git-svn-id: https://origsvn.digium.com/svn/asterisk/trunk@276731 65c4cc65-6c06-0410-ace0-fbb531ad65f3
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index be80977a5..98005f015 100644
--- a/configure.ac
+++ b/configure.ac
@@ -703,8 +703,8 @@ AST_GCC_ATTRIBUTE(always_inline)
AST_GCC_ATTRIBUTE(deprecated)
AST_GCC_ATTRIBUTE(sentinel)
AST_GCC_ATTRIBUTE(warn_unused_result)
-AST_GCC_ATTRIBUTE(weakref, [weakref("foo")], static)
-AST_GCC_ATTRIBUTE(weak_import)
+AST_GCC_ATTRIBUTE(weak_import, [], [], PBX_WEAKREF)
+AST_GCC_ATTRIBUTE(weakref, [weakref("foo")], static, PBX_WEAKREF)
AC_MSG_CHECKING(for -ffunction-sections support)
saved_CFLAGS="${CFLAGS}"