summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGeorge Joseph <gjoseph@digium.com>2016-11-09 17:18:00 -0700
committerGeorge Joseph <gjoseph@digium.com>2016-11-09 19:26:27 -0500
commitedea41126bca8c89e856ff215c13b0fa9ea98f72 (patch)
tree003d607fc22b4a8a27d56bca0905ac869176f42b /configure.ac
parente5860ce07ddf0f81dd20d1b1133a9f95e17976f9 (diff)
build: Fix default values for some SANITIZER options
2 of the sanitizers didn't have default values so in systems that don't support sanitizers menuselect would spit out warnings. They were harmless but confusing. They've now been set to "0". Change-Id: I08dc495e3b83f1feac3160b421f538c375fc5d58
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 0f2148b06..ea55df416 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1115,7 +1115,7 @@ AC_COMPILE_IFELSE(
[AC_LANG_PROGRAM([], [int x = 1;])],
AC_MSG_RESULT(yes)
[AST_ADDRESS_SANITIZER=1],
- [AST_ADDRESS_SANITIZER=]
+ [AST_ADDRESS_SANITIZER=0]
AC_MSG_RESULT(no)
)
CFLAGS="${saved_sanitize_CFLAGS}"
@@ -1131,7 +1131,7 @@ AC_COMPILE_IFELSE(
[AC_LANG_PROGRAM([], [int x = 1;])],
AC_MSG_RESULT(yes)
[AST_THREAD_SANITIZER=1],
- [AST_THREAD_SANITIZER=]
+ [AST_THREAD_SANITIZER=0]
AC_MSG_RESULT(no)
)
CFLAGS="${saved_sanitize_CFLAGS}"